Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 4-Cylinder Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 12-09-2012, 09:53 AM
Learning to use the forums
 
Join Date: Dec 2012
Posts: 12
Default Loping Idle

My truck has been acting up.....at idle rpms will drop suddenly, then jump to 1500-2000. Also while driving engine will shut down or sputter. Runs great most of the time, just does this occasionally. Already replaced fuel pump and idle air control valve. Just bought throttle position sensor and about to install. Any help greatly appreciated.
__________________
1997 4 cyl. 2.3l 180,000 miles 5 speed 2wd extra cab. Work truck.
Reply With Quote
  #2  
Old 12-09-2012, 10:00 AM
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,012
Default

Throttle body cleaning and try cleaning maf sensor

Last edited by 63merc; 12-09-2012 at 10:15 AM.
Reply With Quote
  #3  
Old 12-09-2012, 10:07 AM
Commander Sparkles
 
Join Date: Aug 2010
Posts: 9,275
Default Re: Loping Idle

Might also want to keep an eye and ear out for any possible vaccum leaks
__________________
Truck: 2000 Ford Ranger XLT 4.0 4x4 ext cab
My Build Thread
Mod Ideas
Don't Forget to:
Create a Signature
Show your system

Mods: Brush guard|Front Hitch|Expo Roof Rack|Train Horn|Door/Dash/step/Hood Leds|2" lift|Rear Tow Points|On-Board Air System| 22" & 40" LED bar|and More!
Reply With Quote
  #4  
Old 12-09-2012, 10:15 AM
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,012
Default

Quote:
Originally Posted by reconjb
Might also want to keep an eye and ear out for any possible vaccum leaks
That's a good one
You can use some wd 40 for a easy way to check
Reply With Quote
  #5  
Old 12-09-2012, 10:18 AM
Learning to use the forums
 
Join Date: Dec 2012
Posts: 12
Default Re: Loping Idle

How do i clean throttle body? And thanks for the quick responses.
__________________
1997 4 cyl. 2.3l 180,000 miles 5 speed 2wd extra cab. Work truck.
Reply With Quote
  #6  
Old 12-09-2012, 10:22 AM
Commander Sparkles
 
Join Date: Aug 2010
Posts: 9,275
Default Re: Loping Idle

http://www.fordrangerforum.com/how-s...ttle-body.html
__________________
Truck: 2000 Ford Ranger XLT 4.0 4x4 ext cab
My Build Thread
Mod Ideas
Don't Forget to:
Create a Signature
Show your system

Mods: Brush guard|Front Hitch|Expo Roof Rack|Train Horn|Door/Dash/step/Hood Leds|2" lift|Rear Tow Points|On-Board Air System| 22" & 40" LED bar|and More!
Reply With Quote
  #7  
Old 12-09-2012, 10:31 AM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,412
Default

Quote:
Originally Posted by Greg68w
My truck has been acting up.....at idle rpms will drop suddenly, then jump to 1500-2000. Also while driving engine will shut down or sputter. Runs great most of the time, just does this occasionally. Already replaced fuel pump and idle air control valve. Just bought throttle position sensor and about to install. Any help greatly appreciated.
Stop throwing parts at it. Do maintenance. Did you change fuel filter? Buy a code reader and check for codes. Don't bother going to AZ to get the codes read. ......... Even if the CEL is not on. Read it for codes. You want to try to catch a pending code. Codes are your friend. Make sure the cel comes on koeo

1999, Reg Cab, 2.5, 5 speed, 145k. (Sent from my DROID BIONIC using FRF App)
__________________
2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 113k.(6/5,2014) For-Sale.

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound. UPDATE: I bought a 4.0 out of a 2009 Ranger 4x4, 87k for $800 Just waiting to get the swap done.

Last edited by modelageek; 12-09-2012 at 10:38 AM.
Reply With Quote
  #8  
Old 12-09-2012, 10:35 AM
Learning to use the forums
 
Join Date: Dec 2012
Posts: 12
Default Re: Loping Idle

Thanks for all the good info guys... just joined this forum, it rocks! Going to try cleaning throttle body and replace plugs and wires too, I'll let everyone know how it goes.
__________________
1997 4 cyl. 2.3l 180,000 miles 5 speed 2wd extra cab. Work truck.
Reply With Quote
  #9  
Old 12-09-2012, 10:37 AM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,412
Default

Quote:
Originally Posted by Greg68w
Thanks for all the good info guys... just joined this forum, it rocks! Going to try cleaning throttle body and replace plugs and wires too, I'll let everyone know how it goes.
Check for codes, check for codes, check for codes. Then check for codes!!!!!!!

1999, Reg Cab, 2.5, 5 speed, 145k. (Sent from my DROID BIONIC using FRF App)
__________________
2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 113k.(6/5,2014) For-Sale.

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound. UPDATE: I bought a 4.0 out of a 2009 Ranger 4x4, 87k for $800 Just waiting to get the swap done.
Reply With Quote
  #10  
Old 12-09-2012, 11:35 AM
Learning to use the forums
 
Join Date: Dec 2012
Posts: 12
Default Re: Loping Idle

Checked for codes, nothing came up
__________________
1997 4 cyl. 2.3l 180,000 miles 5 speed 2wd extra cab. Work truck.
Reply With Quote
  #11  
Old 12-09-2012, 01:57 PM
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,012
Default

Then proceed doing the other stuff and we can go from there.
Reply With Quote
  #12  
Old 12-09-2012, 02:19 PM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,412
Default Re: Loping Idle

Quote:
Originally Posted by Greg68w View Post
Checked for codes, nothing came up
Quote:
Originally Posted by 63merc View Post
Then proceed doing the other stuff and we can go from there.
as Merc63 said......proceed doing all the tunuep items,,,,,,clean Tb, EGR, MAF....change air filter and make sure the intake is clear of debris, fuel filter, ......replace if needed, plugs, wires, PCV....look for vacuum leaks by spraying starter fluid around......etc.........

Did you change the fuel filter???????..............keep checking for codes with the reader........you are trying to catch a pending code........
__________________
2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 113k.(6/5,2014) For-Sale.

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound. UPDATE: I bought a 4.0 out of a 2009 Ranger 4x4, 87k for $800 Just waiting to get the swap done.
Reply With Quote
  #13  
Old 12-11-2012, 08:08 AM
Learning to use the forums
 
Join Date: Dec 2012
Posts: 12
Default Re: Loping Idle

Changed plugs, wires, air filter, cleaned throttle body and maf sensor. Runs stronger but still has the loping or hunting idle. Rarely happens....every 10 miles or so avg. Starting to piss me off LOL. Probably going to change fuel filter today. Should have done it while I replaced fuel pump. Oh well.
__________________
1997 4 cyl. 2.3l 180,000 miles 5 speed 2wd extra cab. Work truck.
Reply With Quote
  #14  
Old 12-11-2012, 08:10 AM
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 5,412
Default Re: Loping Idle

Quote:
Originally Posted by modelageek View Post
Don't bother going to AZ to get the codes read. ......... Even if the CEL is not on. Read it for codes. You want to try to catch a pending code. Codes are your friend. Make sure the cel comes on koeo

1999, Reg Cab, 2.5, 5 speed, 145k. (Sent from my DROID BIONIC using FRF App)
I like this guys idea^^^^^^^^^^^
__________________
2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 113k.(6/5,2014) For-Sale.

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound. UPDATE: I bought a 4.0 out of a 2009 Ranger 4x4, 87k for $800 Just waiting to get the swap done.
Reply With Quote
  #15  
Old 12-11-2012, 08:13 AM
Ford Ranger Driver
 
Join Date: May 2012
Posts: 1,012
Default

Quote:
Originally Posted by Greg68w View Post
Changed plugs, wires, air filter, cleaned throttle body and maf sensor. Runs stronger but still has the loping or hunting idle. Rarely happens....every 10 miles or so avg. Starting to piss me off LOL. Probably going to change fuel filter today. Should have done it while I replaced fuel pump. Oh well.
I know on chevys the camshaft position sensor will cause intermittent problems like this. Not saying it is but is a possibility.

You could try this, make sure your mag is functioning properly.

http://easyautodiagnostics.com/ford_...sor_ford_1.php
Sent from my iPhone so you can hate me, wherever I may be.

Last edited by 63merc; 12-11-2012 at 08:19 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle, hunting idle under way, assistance requested Doctor Wily 4-Cylinder Tech 7 10-13-2012 03:33 PM
low idle when slowing down to idle j_huhmke 4.0 SOHC / 4.0 OHV Tech 3 05-03-2012 07:52 PM
rough idle and high idle? Greenbean95 4.0 SOHC / 4.0 OHV Tech 10 01-30-2012 03:13 PM
Intermittent loping idle while at stop light or parked and idling 2.3L Pool Runner 4-Cylinder Tech 1 06-28-2011 07:26 AM
Need idle help 2.9 L 1988ranger 2.9 Liter Tech 1 06-01-2011 12:57 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.