Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-31-2010, 11:29 AM
wsmmpalmer1101 wsmmpalmer1101 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 3
Default No start

Ive got one for anybody out there, Yesterday changed fuel filter which was strange my ranger has the cartiage style filter not the inline open the canistor and there was no filter in it. Pulled #1 plug out and the tip of the plug was missing. Replaced plug and filter, reset timing ohh yea cleaned out throttle body with throttle body spray. Now the truck wont start. Ant ideas???
Reply With Quote
  #2  
Old 01-31-2010, 01:54 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

what year is the truck. you might have tripped the fuel inertia switch. they are usually in the cab on the firewall or passenger side panel at the passengers side feet. does it crank over and not start. was it running before you did the work
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 01-31-2010, 07:10 PM
dylankaut dylankaut is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 2
Default

i am having the same problem my 95 ford ranger was bogging down going up hills and when i would press the gas own. now it wont even start everyone told me to change the fuel filter now it still wont start. any ideas what may be the problem with it????
Reply With Quote
  #4  
Old 02-01-2010, 04:39 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

there is a good chance you have a fuel pressure problem. here are some things to check. you should check the fuel pressure regulator on the fuel rail. Pull the vacuum line off of it and see that you have vacuum and also that there is no fuel in the vacuum line. check to see if you can hear the fuel pump when you put the key to the on position. you should hear the FP for a few seconds. if you have a fuel pressure gauge check that fuel prressure at the shrader valve(looks like a vavle on a tire) you should have about 40. to eliminate any spark issue you can spray starter fluid into the throttle body if it trys to start you have spark and can concentrate on the fuel issue. I have never been to one but I have been told you can get a fuel pressure gauge at Harbor Freight for $10
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 02-04-2010, 07:21 AM
wsmmpalmer1101 wsmmpalmer1101 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 3
Default

Yes it was running but roughly
Reply With Quote
  #6  
Old 02-04-2010, 07:42 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

excellent feedback
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #7  
Old 02-04-2010, 02:31 PM
jfive jfive is offline
Ford Ranger Owner
 
Join Date: Feb 2010
Posts: 52
Default

You still have spark though? start with the obvious and work towards the complicated. spark is the first and fuel is second.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't Start with the key lukeylikadonut Electrical Tech 5 06-12-2010 08:50 AM
Won't start in Park, will start in neutral? jowens2338 3.0 Vulcan Tech 3 02-13-2010 09:12 PM
no start eibbor697 3.0 Vulcan Tech 4 10-28-2009 07:03 AM
94 with 4.0 want start Gene 4.0 SOHC / 4.0 OHV Tech 4 08-23-2009 08:46 PM
Won't start 95 flossin' General Tech 3 05-16-2009 02:05 PM