Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 01-29-2010, 02:49 PM
alex13 alex13 is offline
Learning to use the forums
Join Date: Jan 2010
Posts: 1
Default new and need help

Hello all, not sure if this is the right place to post this, forgive me if its not.
Just bought a 90 Ranger today, its a 4 cylinder, 5 speed, 100k miles.

Well the guy i bought it from drove it here to me from about 15 miles away, when he got here i drove it another mile or so, decided to buy it, and parked it in the driveway. About 10 minutes later i went to drive it to the dmv to get the tags done and all that. I stopped at the gas station on the way, when i came out, the truck wouldnt start. Just kept on cranking, seemed like it would try, but if it did it'd only run for a couple seconds. I had someone spray starting fluid in the intake while i cranked, and it would run. I went and bought a new fuel filter, and that helped none. (The old one was dirty) I'm getting spark, but it seems like its not getting fuel. I can hear the pump though, and it was driven here. What could this be?

Any help would be appreciated
Reply With Quote
Old 01-31-2010, 10:28 AM
modelageek modelageek is offline
Ford Ranger Driver
Join Date: Jan 2009
Posts: 6,145

I think you have a fuel inertia switch and i think it is at the passengers side feet in the cabin on or around the firewall. check that it did not get thrown. if that is OK you should find your fuel pressure regulator. it might be on the fuel rail. check the vauum line to it. Pull it off confirm that there is vacuum and then make sure there is no gas in the vacuum line. if that checks out ok you should do a fuel pressure test. you should have a shrader valve on the fuel rail. you want around 40. make sure you have enough good gas and throw in injector cleaner in the tank
2004 Ext Cab, 4WD, 4.0, Auto, 146k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 3/10/2016)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search