Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-26-2010, 09:32 PM
tsut tsut is offline
HaHa my truck is the best
 
Join Date: Jan 2010
Posts: 12
Default speedo jumping

I was exciting off the highway tonight and my speedometer went to zero. it will start to work when i hit 35 but until then it will jump and every time it jumps my truck will miss out slightly. Its a 2000 xlt 2.5 5 speed. any ideas on what it would be???
Reply With Quote
  #2  
Old 01-27-2010, 07:52 AM
scheider1980 scheider1980 is offline
Ford Ranger Owner
 
Join Date: Nov 2009
Posts: 63
Default

speed sensor
Reply With Quote
  #3  
Old 01-27-2010, 12:41 PM
tsut tsut is offline
HaHa my truck is the best
 
Join Date: Jan 2010
Posts: 12
Default

where is that located?
Reply With Quote
  #4  
Old 01-27-2010, 01:14 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Its the vss/abs sensor located at the top of your differential. I think it is a 10mm bolt. Remove the bolt. Pop out the sensor disconect the electrical conector. I backed my truck up on ramps to make it easeier. I have gone thri 2 AZ $20 sensors. Next time I will try and find a motorcraft
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 01-27-2010, 02:58 PM
tsut tsut is offline
HaHa my truck is the best
 
Join Date: Jan 2010
Posts: 12
Default

That was it!! Thanks for the help! O and i got a napa automatic it was 35$ so hopefully it will last
Reply With Quote
  #6  
Old 01-27-2010, 05:17 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I am glad it worked out for you. one other thought that i had and this is not backed up by any data at all. this is just my theory. after the second sensor went out and i was replacing with the 3rd one i also checked the fluid level in my diff. it was down a quart( it holds about 2.5) I filled it up and replaced the sensor. since then it ihas been fine. I wondered if the low fluid level created any shavings that affected the sensor which i believe is a magnet.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #7  
Old 01-28-2010, 02:35 PM
tsut tsut is offline
HaHa my truck is the best
 
Join Date: Jan 2010
Posts: 12
Default

i just checked the fluid it was a little over a half quart low. Thanks for that too i appreciate the help
Reply With Quote
  #8  
Old 01-28-2010, 02:55 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

While you are on a roll you should change your tranny fluid. There is a drain plug and filler plug on the drivers side. Use mercon atf. I think it is about 3.2. Quarts. Takes about 20 mintes
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle RPM jumping when engine gets wet mattbiasotti General Tech 1 12-06-2010 08:47 AM
Speedo calibration RallyTruck Lifted Suspension 5 01-17-2010 03:59 PM
headlight and speedo prob. jakeshort Electrical Tech 0 12-19-2009 10:17 PM
Jumping a stock ranger :/ Ranger_EDGE Off Topic 29 10-08-2009 04:14 AM
Rpms jumping 15-30 second intervals Pielet 4.0 SOHC / 4.0 OHV Tech 7 08-18-2009 09:53 PM