Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 4-Cylinder Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 06-13-2012, 11:22 AM
Learning to use the forums
 
Join Date: Jun 2012
Posts: 1
Cool location oil sending unit 2.3 engine?

Bought this truck month ago, two weeks later Check Oil light comes on occasionally, doesn't seem to make any difference fast or slow running. This week seems to stay on all the time. Gauge on the dash (I'm told its a dummy gauge... what a stupid idea!) reads normal. Oil level is good. Thought to change the sending unit... but can't find it. Any ideas?

Robert in Mendo
1994, 2.3 L engine
__________________
Work Truck - 1994 Ranger, XTL, 4 cyl 2.3L (140 CID) SOHC, 5 speed Manual, standard bed
Reply With Quote
  #2  
Old 06-13-2012, 07:37 PM
Tank Diver
 
Join Date: Mar 2010
Posts: 3,056
Default

Don't know on your particular engine but on the 2.5, it's on the back of the head on the driver's side. Since the 2.3 and 2.5 have many similarities, it might be in the same place. Mine has a single pole that the plug goes on and threads right into the head.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #3  
Old 06-14-2012, 01:44 PM
Ford Ranger Driver
 
Join Date: Jun 2012
Posts: 1,961
Default

Quote:
Originally Posted by sgtsandman
Don't know on your particular engine but on the 2.5, it's on the back of the head on the driver's side. Since the 2.3 and 2.5 have many similarities, it might be in the same place. Mine has a single pole that the plug goes on and threads right into the head.
Correct bro

GO GO POWER RANGER!!!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure with disconnected sending unit. RHK 3.0 Vulcan Tech 0 01-23-2012 08:07 AM
Oil leak on back of motor. Oil press sending unit? Tommy2 3.0 Vulcan Tech 8 08-18-2011 10:35 AM
92 Ranger 4 Cyl Oil Sending Unit... jfreakofkorn 4-Cylinder Tech 0 08-09-2011 09:26 AM
Where's my Oil Pressure Sending Unit? 02Edge 3.0 Vulcan Tech 1 05-12-2010 09:23 AM
92 4.0 low oil sending unit Clem 4.0 SOHC / 4.0 OHV Tech 0 10-03-2009 08:01 AM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.