Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-16-2010, 03:58 PM
bmacranger bmacranger is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 3
Default new intake. check engine light on, sputtering

I'm a novice when it comes to this but If someone could lend me some words of wisdom, i bought an intake kit at autozone for my 97 ford ranger single cab, 2.4L. when i start the truck it sputters and stalls, will do it until i give it some gas, and when i start driving for about the first 5 minutes it sputters and lunges, anyone who can help; post or gimme a buz at 603 686 2997 names bryan
Reply With Quote
  #2  
Old 01-16-2010, 04:02 PM
Mustangc97 Mustangc97 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 10
Default

A cold air intake system?
__________________
2006Ford Ranger XLT 4 door 4.0, Auto, 4x4.
Reply With Quote
  #3  
Old 01-16-2010, 04:30 PM
smakes smakes is offline
Banned
 
Join Date: Sep 2009
Posts: 3,005
Default

take it back to autozone and ask them to read the code its throwing. they can tell you more
Reply With Quote
  #4  
Old 01-16-2010, 05:03 PM
bmacranger bmacranger is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 3
Default

yea its an air intake, check engine lights on still, im bringing it to autozone tomorrow so ill know more then.
Reply With Quote
  #5  
Old 01-16-2010, 05:15 PM
Jp7 Jp7 is offline
DISABLE ADBLOCK: LOLZ
 
Join Date: Dec 2009
Posts: 1,438
Default

sounds like a big mess of unmetered air, or a malfunctioning maf.
__________________
Looking for a professional retrofitter to add HIDs or LEDs to your Ranger? PM me if your looking to have work done, and have cash to spend.

Quote:
Originally Posted by FireRanger View Post
I'm dying to see this at night. Someone go tell the sun to give up already.
Quote:
Originally Posted by beef08 View Post
Your the man, you bring our dreams to a reality within the lighting spectrum
Quote:
Originally Posted by BCobe View Post
Jp7 you always do AMAZING work! Hats off to you sir
Quote:
Originally Posted by FireRanger View Post
People so often confuse "hating" with "knowing better".
Reply With Quote
  #6  
Old 01-17-2010, 11:50 AM
bmacranger bmacranger is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 3
Default

all of the sensors are plugged in, but now it still sputters when started and when i start moving it bogs down and wont accelerate at all, and then lunges
Reply With Quote
  #7  
Old 01-17-2010, 01:57 PM
Jp7 Jp7 is offline
DISABLE ADBLOCK: LOLZ
 
Join Date: Dec 2009
Posts: 1,438
Default

if this were me i would see what my MAF is reading with my scanner live data. hint hint...
__________________
Looking for a professional retrofitter to add HIDs or LEDs to your Ranger? PM me if your looking to have work done, and have cash to spend.

Quote:
Originally Posted by FireRanger View Post
I'm dying to see this at night. Someone go tell the sun to give up already.
Quote:
Originally Posted by beef08 View Post
Your the man, you bring our dreams to a reality within the lighting spectrum
Quote:
Originally Posted by BCobe View Post
Jp7 you always do AMAZING work! Hats off to you sir
Quote:
Originally Posted by FireRanger View Post
People so often confuse "hating" with "knowing better".
Reply With Quote
  #8  
Old 01-18-2010, 06:28 PM
Mustangc97 Mustangc97 is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 10
Default

MAF issue. Depending on type and brand of cold air intake they can create this issue. I would also check for an air leak betweek the MAF sensor and the throttle body. If your getting unmetered air it will cause these issues.
__________________
2006Ford Ranger XLT 4 door 4.0, Auto, 4x4.
Reply With Quote
  #9  
Old 01-18-2010, 08:14 PM
98blownranger 98blownranger is offline
Custom KeyChain R Me
 
Join Date: Feb 2009
Posts: 718
Default

did you remove your MAS?? or is it unplugged. send me a photo
__________________
Quote:
Originally Posted by redrumedge View Post
98blown you should be an MD! that's the same stuff my doc asks and ur spot on man!!!
98 4.0 2wd-----supercharger fully build heads cam...all show with go......3 time world of wheels champ 5 time national winner


lots of ranger parts for sale leftovers from my 94/96
96 sitting on the frame, waiting to go lower


custom billet parts by me intake adapters and billet steps for the step sides

please sign my guestbook!!
http://breyperformancemachine.shutterfly.com/

Last edited by 98blownranger; 07-31-2010 at 06:53 AM.
Reply With Quote
  #10  
Old 01-31-2010, 01:15 AM
sho_or_go sho_or_go is offline
!ranger anger!
 
Join Date: May 2009
Posts: 59
Default

i would say to hell with the "CAI" and put the stock intake back in the truck.
__________________
RANGER
Reply With Quote
  #11  
Old 01-31-2010, 11:58 PM
bruiser bruiser is offline
Liking the Ford Ranger Forum
 
Join Date: Jan 2010
Posts: 20
Default

did you put the MAF on the right way ive put mine on backwards before
Reply With Quote
Reply

Tags
ranger intake fuck my day

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light Bear Electrical Tech 11 03-21-2010 12:32 AM
RE-2.5 check engine light velozp 4-Cylinder Tech 0 01-02-2010 04:12 AM
check engine light on 2.5 velozp 4-Cylinder Tech 12 12-25-2009 10:47 AM
Check engine light after new intake installed DangerRanger17 General Tech 6 12-25-2009 09:03 AM
check engine light RangerLuc General Ford Ranger Discussion 15 10-06-2009 05:34 AM