Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-13-2010, 05:51 PM
94 s-box 94 s-box is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 5
Default 94 2.3 rough idle, delayed accel

94, 4x4, 2.3, manual. ive had a rough idle with this mutha ever since i bought her a year ago. sometimes its bad, sometimes not so much. ive looked for vac leaks, checked pcv, new plugs and wires, checked coil packs w multimeter, new iac valve, new tps. it sounds like its misfiring after sitting at idle for a bit, rpms are fairly stable but the truck can shake bad. recently (been getting cold out) truck has been real bogged down when accelerating from a stop. just "put put put" with pedal to the metal, then "vroom" it catches on. a dude i work with told me to check out my thermostat (without a working one the injectors will never work right) so i replaced that, and from the looks of the old one, that was a good call. still truck inconsistantly has that bogged down accel prob, which happens in any gear (full throttle, "put put put" then "vroom"). now back to the idle, when it idles real bad i can pop the hood, unplug the mass air flow sensor and BAM it clears right up. no missing, no shaking, just sweet smoothness. however, my delayed acceleration seems much more likely when driving without the MAF. ive tryed cleaning the MAF, no luck. i know unpluging her sends the truck into a different computer mode. anyone think i should replace the MAF? i may pull one from a junkyard tomorrow. thoughts? and thanks
Reply With Quote
  #2  
Old 01-13-2010, 08:47 PM
smsranger smsranger is offline
smsranger
 
Join Date: Oct 2009
Posts: 536
Send a message via AIM to smsranger
Default

my trucsk doing the same...nut not as bad..the other day it seemed lke it was going to die on me wen i threw the clutch in. my volt meter dropped then shot back up. i was told it might be a ground somewere
__________________
iv got a 94 ford ranger. most baisic truck u can ever get. no power stearing. manual locks and windows. got a JVC KDR200, with a pair of Pyle 6" X 8" Blue Label 3-Way Speakers and wired an antennna. its a 2.3L 4 banger, with a 5 speed manual transmission. it had 117,400 miles on it wen i got it. i plan on dropping it a few inches. in the procces of repainting the interior. i want new headlights and taillights and paint my factory rims black. plan on getting a cheap sub and put in it.
Reply With Quote
  #3  
Old 01-14-2010, 06:25 AM
94 s-box 94 s-box is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 5
Default

ill try to look into that, thanks for the info. even with the MAF out sometimes it will rev real high right out of the blue. could totally be electrical. now i need to learn how to "check grounds"
Reply With Quote
  #4  
Old 01-14-2010, 02:36 PM
Jwo Jwo is offline
Learning to use the forums
 
Join Date: Dec 2009
Posts: 11
Default

Hey I think my truck is doing the same thing. I don't have a rough idle, but I do have a delayed acceleration. I replaced my plugs and wires, MAF, cat converter, exhaust, intake, all within the last year or so. It runs really smooth, but it still seems to have a hesitation when I first accelerate "(full throttle, "put put put" then "vroom")"...I had to change my battery yesterday so my car went back to it's original specs (sensors and whatnot). It ran much more smoothly this morning, and there is ZERO hesitation in the acceleration, amazing. Funny thing about the sensors however, if they sense a problem, (ie: too much O2 in the exhaust) they try to fix it by adding more fuel and messing up the a/f ratio. I'm thinking after I drive it for a while, it'll go back to it's crappy settings and i'll be back at square one...I was reading a post on another site that I was considering of doing it since I've never changed my O2 sensors and they're over 13 years old. This is my next option if my car goes to "crap" mode again. Hope this helps dude

http://www.rangerpowersports.com/for...ighlight=p1443
__________________
1996 Ranger XLT 2.3L 5spd
Clear Corners
Magnaflow Cat
Dynomax Superturbo exhaust system
Wrangler 15x7 rims
31x10.5 Steel radials
Reply With Quote
  #5  
Old 01-14-2010, 05:55 PM
94 s-box 94 s-box is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 5
Default

thanks for the info dude. i pulled a MAF sensor out of a junker today, truck seems like its got more powerful accel now, but still idles like crap. ill look into an O2 sensor
Reply With Quote
  #6  
Old 01-15-2010, 07:30 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

I have heard that the water tenp sensor can go bad and feed the pcm bad info
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #7  
Old 01-15-2010, 12:37 PM
smsranger smsranger is offline
smsranger
 
Join Date: Oct 2009
Posts: 536
Send a message via AIM to smsranger
Default

dam there is to much shit to look at for 1 problem..lol. y cant shit just be simple
__________________
iv got a 94 ford ranger. most baisic truck u can ever get. no power stearing. manual locks and windows. got a JVC KDR200, with a pair of Pyle 6" X 8" Blue Label 3-Way Speakers and wired an antennna. its a 2.3L 4 banger, with a 5 speed manual transmission. it had 117,400 miles on it wen i got it. i plan on dropping it a few inches. in the procces of repainting the interior. i want new headlights and taillights and paint my factory rims black. plan on getting a cheap sub and put in it.
Reply With Quote
  #8  
Old 01-15-2010, 02:57 PM
94 s-box 94 s-box is offline
Learning to use the forums
 
Join Date: Jan 2010
Posts: 5
Default

yeah ive been interested in testing my temp sensor. ive tryed unplugging it, made no difference. the metal housing it sits in is real rusted. anyone know how to test these guys?
Reply With Quote
Reply

Tags
bogging down, delayed acceleration, maf, rough idle

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
94 2.3 rough idle, delayed accel 94 s-box 4-Cylinder Tech 1 02-06-2010 06:24 PM
ROUGH Idle 1997 4.0 V-6 What to look 4 ? glarestop 4.0 SOHC / 4.0 OHV Tech 2 10-21-2009 02:03 PM
Question: rough idle amp_lee78 4.0 SOHC / 4.0 OHV Tech 3 09-06-2009 02:41 PM
Rough Idle Jimmyboiii 4-Cylinder Tech 5 08-24-2009 05:01 AM
1993 2.3L rough Idle 93RedRanger 4-Cylinder Tech 1 08-06-2009 09:42 AM