Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-20-2012, 04:09 PM
nathanb nathanb is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 5
Default 2008 4x4 3lt desiel hard to start an runs rough

i have a 2008 ranger an its hard to start mainly when its been sitting for 3hrs or more once it has started it runs rough for maybe 1min an blows alot of smoke. i have changed all glow plugs no luck had engine light come on so took to mechanics to clear had a cylinder 4 misfire so they serviced all fuel injectors, have changed oil to synthetic oil, changed fuel filter, an still no luck would appreciate ANY help please
Reply With Quote
  #2  
Old 03-21-2012, 04:39 AM
chudzikb chudzikb is offline
Like the Forums
 
Join Date: Jan 2012
Posts: 30
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

I know VW diesels. That said, what type of a fuel system does your 08 have? Are you common rail? Or an older rotary design? If it were a VW, I would say your fuel is draining back due to a leak in the line somewhere? It is actually all reasonably simple in the diesel, fuel, timing of the fuel, compression, boom it runns. How is your battery? You need a certain RPM to get it started, at least on VW's.
Reply With Quote
  #3  
Old 03-21-2012, 06:22 PM
nathanb nathanb is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 5
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

it is a common rail turbo i though it mite be the primer on the fuel filter housing but they told me it was ok, battery is ok
Reply With Quote
  #4  
Old 03-22-2012, 03:28 AM
chudzikb chudzikb is offline
Like the Forums
 
Join Date: Jan 2012
Posts: 30
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

I got nothing for you, sadly... Not familiar with the common rail as much as the older designs. Are you going to the dealer on this problem? If they are not figuring it out seek out another dealer or an aftermarket shop in your area that knows your engine? Good luck!
Reply With Quote
  #5  
Old 03-22-2012, 06:09 AM
ddunfee ddunfee is offline
Ford Motor Co
 
Join Date: Jan 2011
Posts: 169
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

know you said you changed the glow plugs but it still sounds like the glow plugs aren't working.
Reply With Quote
  #6  
Old 03-22-2012, 06:10 PM
nathanb nathanb is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 5
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

thats what i thought have since been told it could be a bad wire somewhere, the dealer is a 4hr drive away som am dealing with the largest desiel specialist in my town, am gonna have another look at glow plugs an see if i get anywhere, thanks for the help
Reply With Quote
  #7  
Old 03-23-2012, 06:35 PM
deereman75 deereman75 is offline
Learning to use the forums
 
Join Date: Nov 2011
Posts: 7
Default

Sounds like your glow plug controller is not cooperating to ignite your plugs at all or not long enough!!!
__________________
Deereman75
Reply With Quote
  #8  
Old 03-30-2012, 04:19 AM
nathanb nathanb is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 5
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

Have checked glow plugs an they are working fine have also got mechanics to check electrical harness for injectors an have ruled that out, this is really starting to piss me off
Reply With Quote
  #9  
Old 03-30-2012, 12:48 PM
chudzikb chudzikb is offline
Like the Forums
 
Join Date: Jan 2012
Posts: 30
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

If its warm out and glow plugs are not working, no issue, if cold and no glow plugs then issue. You guys are reverse of us season wise, so its cooler now? Try keeping in a warm garage and see what happens?
Reply With Quote
  #10  
Old 03-30-2012, 11:18 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

Sounds like you have an air leak. it's a slight leak, so the truck sits, and leaks fuel back down, letting air in the system. Once the truck starts, it'll run rough for a minute or two, then start running ok as the fuel builds back up. I'm a certified diesel tech, and that's what I've seen with them. I'd say it's on the lift pump side up to the injection pump.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #11  
Old 03-31-2012, 04:03 AM
chudzikb chudzikb is offline
Like the Forums
 
Join Date: Jan 2012
Posts: 30
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

I would agree with above, except for he probably has a lift pump that after a second would eliminate that problem? Were just guessing as we have never seen what he has in north america. They keep the good stuff from us.
Reply With Quote
  #12  
Old 03-31-2012, 07:22 AM
ddunfee ddunfee is offline
Ford Motor Co
 
Join Date: Jan 2011
Posts: 169
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

Well the white smoke told me you are getting fuel. You do get air and if the glow plugs are working you are getting heat. That leaves the speed of the starter. Does it turn over slow?
Reply With Quote
  #13  
Old 03-31-2012, 08:09 PM
nathanb nathanb is offline
Learning to use the forums
 
Join Date: Mar 2012
Posts: 5
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

it will mis fire some times when its been sitting for awhile, it doesnt matter if its cold outside it will only do it when its been sitting for 3hrs or more
Reply With Quote
  #14  
Old 03-31-2012, 09:40 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: 2008 4x4 3lt desiel hard to start an runs rough

Quote:
Originally Posted by chudzikb View Post
I would agree with above, except for he probably has a lift pump that after a second would eliminate that problem? Were just guessing as we have never seen what he has in north america. They keep the good stuff from us.
That doesn't eliminate it all, because air compresses, so air in the injection pump will cause the smoking, because the injector first has to push out the air before it pushes out the fuel, and with the compression of the air, it also expands when the injector opens, causing it to take a bit to expel all the air in the lines.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
Reply

Tags
blows smoke, hard to start, runs rough after restart

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine hard to start and runs rough when started ranger2.3 4-Cylinder Tech 0 01-06-2012 04:11 PM
1994 2.3 runs rough hard to start cant drive NEED HELP Pistol Pete 4-Cylinder Tech 5 12-02-2011 07:51 PM
hard start, no start, ruff idle, poor gas mileage n more terryduanemiller General Tech 1 01-11-2011 09:42 AM
My 88 with 2.9 runs rough jimandpam 2.9 Liter Tech 13 10-18-2010 04:31 AM
94 4.0L runs rough when first started alabamafrog 4.0 SOHC / 4.0 OHV Tech 1 05-07-2010 04:41 AM