Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-02-2010, 04:44 PM
pvcooper pvcooper is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 32
Default 1993 ford ranger 2.3

this has been boggling me for a few months now.
My ranger has been missing really bad for the past few month, all the time,not just when i first start it but constanly.It started when my catalytic converter stopped up ,so i cored it out, it melted 2 of my spark plugs , so i changed all eight of them,then i changed the egr valve sensor,idle air control sensor,o2 sensor.Well then started burning oil really bad so i replaced the valve steam seals.It idles with a horrible miss,and runs with a sputter. Im only getting 142 miles on a full tank of gas, and only thing left i think i could replace is the ecm. ANY IDEALS
Reply With Quote
  #2  
Old 01-02-2010, 06:53 PM
Vince M Vince M is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 6
Default

1. Check the resistance of the plug wires, replace all if any are bad.
2. Check the resistance of the coil packs, replace if defective.
3. Have your local parts place check the Ignition Control Module. Make sure they check the ICM several times so it is at operating temperature.

Any of these could cause your miss-fire and poor gas milage. Also make sure your MAF and Throttle Body are both clean.
Reply With Quote
  #3  
Old 01-02-2010, 08:06 PM
pvcooper pvcooper is offline
Like the Forums
 
Join Date: Jan 2010
Posts: 32
Default

yea i replaced the wires when i replaced the plugs , when my check engine light was on the first thing i did was clean the maf sensor an change filter. but now my check engine light is off .
__________________
93 Ranger XL 2.3 15" wheels 5 speed trany
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 ford ranger wont start awsskater4life76 General Ford Ranger Discussion 8 12-06-2009 07:11 AM
FOR SALE!! 1993 Ford Ranger Stepside getmoney Trucks 3 07-24-2009 01:07 PM
1993 ford ranger MUPH Introduce Yourself 5 07-09-2009 07:31 AM
1993 ford ranger wheel base.? guitarplayer574 Wheels and Tires 1 01-20-2009 12:29 AM
1993 ford ranger with the quad 4? Jeremy D General Ford Ranger Discussion 1 01-01-2009 02:44 PM