Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Engine Tech Forum > 4-Cylinder Tech
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 01-10-2012, 07:22 PM
Learning to use the forums
 
Join Date: Jan 2012
Posts: 1
Default 99 2.5 running horrible after timing belt install

i bought a 99 ford ranger knowing it was running bad. seller just had timing belt installed and it was still was running bad. i rechecked the timing and it is set right. even swapped the cam 180 degrees out and no change which makes no sense to me. it runs real shaky and has no power. threw a code for misfire on cylinder 3 and went off. you rev the truck up and it dies and when you go to crank it seems to have no compression for a couple of turnovers then it cranks up. had the truck put on a scanner and at idle the timing was jumping around. im clueless and need advice thanks
Reply With Quote
  #2  
Old 01-11-2012, 03:17 AM
Ford Tough
 
Join Date: Nov 2010
Posts: 280
Default Re: 99 2.5 running horrible after timing belt install

If it ran fine before the timing belt went,it has to be something that coincides with that.Either the crank sensor got hit with the belt,cam sensor off or it still is not timed right.As long as it ran fine before the belt.
Reply With Quote
  #3  
Old 02-24-2012, 02:53 PM
Learning to use the forums
 
Join Date: Feb 2012
Posts: 1
Default Re: 99 2.5 running horrible after timing belt install

same mess 99 ranger timing belt broke in shop but running bad no power
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
belt tensioner and timing belt chain MinniePearlsOwner General Tech 2 04-20-2011 02:19 PM
Timing Belt Install - No Start Issues Ranger X 4-Cylinder Tech 2 04-16-2011 06:42 PM
timing belt/cam timing issue omegatotal Drivetrain Tech 0 01-08-2011 02:18 PM
Timing belt or timing chain? Gonzos xlt 4-Cylinder Tech 8 09-27-2010 06:20 AM
Horrible gas mileage, I mean horrible..... Millerman General Tech 60 08-13-2010 07:32 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.