Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-24-2009, 05:09 PM
2001ranger 2001ranger is offline
Learning to use the forums
 
Join Date: Nov 2009
Posts: 2
Default 2001 2.3L Ranger Temp. Gauge Problem

The Temperature Gauge on my 2001 2.3L Ranger never moves (stays at zero always). I have replaced the whole thermostat assembly and was wondering what other problems I could be looking at. Also could it just be a loose connection and does anyone have a schematic of the cooling system?
Reply With Quote
  #2  
Old 10-25-2011, 11:01 AM
Dictator1937 Dictator1937 is offline
Learning to use the forums
 
Join Date: Oct 2011
Posts: 2
Default Re: 2001 2.3L Ranger Temp. Gauge Problem

I have a problem with the temp gauge and the oil gauge pegged out under the L (low) on start up. After running for 10 or 15 seconds, the oil gauge makes a quick move to the center of the range and stays there. Only noticed it because the check gauge light illuminated for a couple of minutes, then when out. Oil level is good.

The temp gauge has not, of course, moved yet, because the engine has not warmed up to temp. Anyone seen this problem on the oil gauge?

Thanks, Joe
Reply With Quote
  #3  
Old 10-25-2011, 05:12 PM
sheltonfilms sheltonfilms is offline
Junkyard Dog
 
Join Date: Sep 2010
Posts: 1,842
Default Re: 2001 2.3L Ranger Temp. Gauge Problem

Oil pressure switch sounds bad on the second post.

As for the OP, 2001 was a weird year for 4 cyl rangers half were 2.3 DOHC and half were 2.5 SOHC. Which do you have?

Do you have heat?
__________________
Automotive Electronics Engineer
2000 XLT 2.5L A/T
Mods:
Explorer OHC
Explorer Autodim Mirrors w/ Autolamps
Explorer Sport White Face Gauges
Reply With Quote
  #4  
Old 10-26-2011, 06:10 AM
Dictator1937 Dictator1937 is offline
Learning to use the forums
 
Join Date: Oct 2011
Posts: 2
Default Re: 2001 2.3L Ranger Temp. Gauge Problem

My bad for not clarifying engine size; I have the 4.0, 6cyl.

Gauge appears to work after the initial 15 second hang up.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
temp gauge adk General Ford Ranger Discussion 2 06-02-2011 04:13 PM
low temp on gauge,2.3 engine 2002 jmm03 4-Cylinder Tech 17 04-25-2011 11:41 AM
Temp Gauge Not Registering taz General Tech 9 11-26-2010 05:14 AM
Temp gauge not functioning twdavis416 Electrical Tech 2 11-23-2009 06:19 PM
oil temp problem please help mb128 3.0 Vulcan Tech 5 10-25-2009 10:19 PM