Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-08-2009, 07:31 PM
mr cribb mr cribb is offline
Ford Ranger Owner
 
Join Date: Oct 2009
Posts: 62
Default 1994 Radiator

So when coming out of the gas station today I notice my truck pissing out the fun green stuff. I traced the leak to be 1/4 way above the drain ****. Looks as though it may be leaking in between the plastic tank and actual metal core itself.

Is there a quick/cheap/semi-permanent way to fix this?

Junk yards want between 50-100 for used, and local autozone wants 140 for new.

Truck is just a few miles shy of 229k, everything looks original even down to the hoses.

Thanks in advance,
Jeremy
__________________
1994 sun faded (New Mexico/Texas truck) maroon, regular cab, 2.3 5 speed & 3.73's. Bought w/ 227k and climbing.
Reply With Quote
  #2  
Old 11-11-2009, 11:13 AM
marchev marchev is offline
94 Ranger 2wd
 
Join Date: Oct 2009
Posts: 5
Default

I have the same exact problem in my 94 ranger and im saving for a new radiator cuz i dont think anything else will fix it. Till then just keep topping off with coolant
Reply With Quote
  #3  
Old 11-11-2009, 12:48 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Rock auto has a radiator for $86 for your truck That's the best solution. You could use a sealer to stop it temporarily I think your truck was a 94so if your heater core did get clogged it is easy to change. Maybe I can start a debate about the use of radiator sealers. (Evil grin)
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 11-11-2009, 07:57 PM
wayneinfl wayneinfl is offline
Liking the Ford Ranger Forum
 
Join Date: Nov 2009
Posts: 17
Default

try changing the cap first. i had the same problem and thats what it was
Reply With Quote
  #5  
Old 11-12-2009, 05:16 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default

Quote:
Originally Posted by wayneinfl View Post
try changing the cap first. i had the same problem and thats what it was
I am confused what problem did changing the rad cap solve?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #6  
Old 11-12-2009, 08:57 PM
wayneinfl wayneinfl is offline
Liking the Ford Ranger Forum
 
Join Date: Nov 2009
Posts: 17
Default

o my bad. i read to quickly
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is my radiator coolant.... FreestylinDirtbiker 3.0 Vulcan Tech 11 04-07-2014 04:30 AM
Radiator?? Dusty 4.0 SOHC / 4.0 OHV Tech 6 08-14-2010 09:56 AM
Radiator Problem Bear General Tech 17 09-24-2009 09:55 PM
Radiator Help Bear General Tech 19 08-29-2009 09:01 AM
Radiator/coolant question Red98 3.0 Vulcan Tech 0 07-05-2009 06:39 PM