Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-02-2011, 12:28 PM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default 87 runs 4-6 miles and quits

87 ranger with 2.3 stops running after 4 to 6 miles - on initial start sometimes stalls/ immediate restart and then good - just before shut down has hard time upshifting- computer self tests - engine cranks good - timing dead on - not overheating -- new components - distributor, coil, control module(TFI), pickup, trans sender, fuel and ecm relay, ECM, temp sensor - high pressure pump and filter - MAP - O2 sensor - ignition switch assembly. When it quits it can be 5 hrs before restart - it then runs a little rough like the computer is off time for about a mile and the smooths out. 6 months ago it would shut off and turning the key on and off would restart - got progressively worse - not throwing ANY codes. Truck has 358k - want to keep her - no rust and emissions 85% of new last year Suggestions please.
Andy

Last edited by Searcherwolfe; 08-02-2011 at 04:40 PM.
Reply With Quote
  #2  
Old 08-02-2011, 01:28 PM
MaDDMike740 MaDDMike740 is offline
404 Error...
 
Join Date: Feb 2011
Posts: 99
Default Re: 87 runs 4-6 miles and quits

clogged up cadillatic converter?
__________________
2000 Ford Ranger XLT 2WD 2.5
168,000 miles
235/75/15
Reply With Quote
  #3  
Old 08-02-2011, 04:09 PM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default Re: 87 runs 4-6 miles and quits

Thanks for the reply
converter is not restricting exhaust - truck quits like someone shut the key off
Reply With Quote
  #4  
Old 08-02-2011, 04:10 PM
mt1986 mt1986 is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 12
Default Re: 87 runs 4-6 miles and quits

check the electrical connections at the fuel injector, corrosion there can cause some weird driveability problems, my 86 would act like it was running out of gas, eventually becoming worse, i went the same route you did and replaced just about everything with no improvement, upon inspection of connections i found corrosion in 3 of the 4 injector connections, since cleaning them it runs and drives better than it every has no issues no pinging, i also found the low pressure pump in tank to have a bad piece of rubber hose basically the hose conecting the pump to the straw was totally disolved, like the fuel additives ate it, so it would cavitate the high pressure pump at about 3/4 tank, when i found that i thought for sure it was it, but i was wrong, drove ten minutes and pushed it home. cleaning the injector connections solved the problem i removed the top half of the intake manifold to gain access to the injectors, be sure to use dielectric grease when reassembling the connections, good luck
__________________
mt1986
Reply With Quote
  #5  
Old 08-02-2011, 04:35 PM
Searcherwolfe Searcherwolfe is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 9
Default Re: 87 runs 4-6 miles and quits

Thanks for the info - next project is the tank pump just because - but fuel pressure is good when system is powered. - Injector wiring has not been cleaned
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Ranger 532,000 Miles (Half a million miles) audyjl Introduce Yourself 25 09-16-2014 01:34 PM
most miles on a 2010 or 2011 miles... batter up!!! 2010 General Ford Ranger Discussion 20 06-23-2014 05:25 PM
runs 4-6 miles and quits Searcherwolfe 4-Cylinder Tech 5 05-21-2011 05:13 PM
Quits Running wotherp General Tech 0 03-07-2011 11:38 AM
6-Cyl Engine Quits On '95 XLT Gulfoyster General Tech 0 02-18-2010 08:42 PM