Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-02-2011, 04:31 AM
2006ranger 2006ranger is offline
Learning to use the forums
 
Join Date: Aug 2011
Posts: 5
Default 06 2.3 ranger

hi, im having trouble with my ranger,its a 06 2.3 2wd.

out of the blue yesterday,it started hesistating and missing on takeoff from a stop,as i step the gas in it continues to feel like its missfiring then catches itself and pulls.if i rev it in neutral, the hesistation/misfire disappears as the rpms rise, if i push the gas pedal sharply it hesitates as well.has a lopey/rough idle,no CEL on,replaced fuel filter yesterday,ohmed the coiled its good,plugs are good,im leaning towards a sensor or clogged injector.please any input would be great as its my daily drive.also the wires and plugs still working.thanks.

Last edited by 2006ranger; 08-02-2011 at 04:34 AM.
Reply With Quote
  #2  
Old 08-02-2011, 07:32 AM
MaDDMike740 MaDDMike740 is offline
404 Error...
 
Join Date: Feb 2011
Posts: 99
Default Re: 06 2.3 ranger

dump some marvel mystery oil down the tank and run it that should clear up any clogs. i would also check the fuel pressure maybe the pump is going out.
__________________
2000 Ford Ranger XLT 2WD 2.5
168,000 miles
235/75/15
Reply With Quote
  #3  
Old 08-02-2011, 08:40 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: 06 2.3 ranger

Quote:
Originally Posted by 2006ranger View Post
hi, im having trouble with my ranger,its a 06 2.3 2wd.

out of the blue yesterday,it started hesistating and missing on takeoff from a stop,as i step the gas in it continues to feel like its missfiring then catches itself and pulls.if i rev it in neutral, the hesistation/misfire disappears as the rpms rise, if i push the gas pedal sharply it hesitates as well.has a lopey/rough idle,no CEL on,replaced fuel filter yesterday,ohmed the coiled its good,plugs are good,im leaning towards a sensor or clogged injector.please any input would be great as its my daily drive.also the wires and plugs still working.thanks.
-any chance you got bad gas

-do a fuel pressure test

- coils can ohm out OK and still be bad

- try and catch a "pending" code........I solve many issues this way
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #4  
Old 08-02-2011, 07:10 PM
2006ranger 2006ranger is offline
Learning to use the forums
 
Join Date: Aug 2011
Posts: 5
Default Re: 06 2.3 ranger

i have to say this haynes manual sucks it doesnt say how to measure the mass air or tps just how to remove and replace.

i changed to a new oem coil-no change,different wires and new plugs-no change-does anyone know what psi the pump should put out?and how to manuall clean injectors?oh fresh gas and stp fuel system treatment-no change.once again no cel light.sprayed carb cleaner on vacuum lines and checked connectors.

modelageek-where do i find the pending code?
Reply With Quote
  #5  
Old 08-08-2011, 11:56 PM
2006ranger 2006ranger is offline
Learning to use the forums
 
Join Date: Aug 2011
Posts: 5
Default Re: 06 2.3 ranger

is 10-12 psi, key on engine off normal,60-62 psi while idling?(fuel pressure)
Reply With Quote
  #6  
Old 08-09-2011, 04:29 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: 06 2.3 ranger

No kOEO should be about 60 also. Cycle the key 2 or 3 times if the psi is not about 60. You have an issue. Change the FF if you have not done so

----------

A pending code can be found by checking for codes the usual way. Your CEL will be off and you might still have a "pending" code, however you prob found your issue with FP. Change your FF, if that does not solve it you need a FUel pump
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #7  
Old 08-09-2011, 09:11 PM
2006ranger 2006ranger is offline
Learning to use the forums
 
Join Date: Aug 2011
Posts: 5
Default Re: 06 2.3 ranger

cycle the key on and off 6 times finally reached 60-62 psi,changed the fuel filter yesterday.....
Reply With Quote
  #8  
Old 08-09-2011, 09:20 PM
cacher cacher is offline
Grumpy Ole Man
 
Join Date: Mar 2010
Posts: 1,012
Default Re: 06 2.3 ranger

Clean the MAF?
__________________
Cree Proverb

~Draw me not without reason, Sheath me not without honor~ 17th century swordmaker Gallegos

~1994 Ford Ranger 2.3L 4-Banger 217, 000+miles~
Reply With Quote
  #9  
Old 08-10-2011, 05:36 AM
2006ranger 2006ranger is offline
Learning to use the forums
 
Join Date: Aug 2011
Posts: 5
Default Re: 06 2.3 ranger

yes, cleaned maf sensor,i noticed the idle doesnt change plugged in or not.......truck still runs without it......
Reply With Quote
  #10  
Old 09-21-2011, 08:28 PM
Red31 Red31 is offline
Sellout
 
Join Date: Apr 2011
Posts: 2,449
Default Re: 06 2.3 ranger

Ever find a solution? I'm having a similar problem. Not exactly the same but you may be able to give me an idea of what to try next, Thanks!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search