Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-25-2011, 04:16 PM
leftofsanity leftofsanity is offline
Learning to use the forums
Join Date: Apr 2011
Posts: 14
Default 94 2.3l Timing right?

Trucks been running real bad, wont stay running when cold. Found cylinder 2 & 3 on exhaust side wasnt firing. Found out bad ICM, changed. replaced coolant sensor and IAC valve. Better, but stil runs bad.

Decided to test timing, this is what I found.

I disco'd the SPOUT connector ( I think, I followed the pink wire in the diagram from book and found a single connector, with 2 pink wires, had a single plastic plug)

I then checked the timing with the light, and the plastic guide was labelled BTC---->20--->10--->TC

The mark was showing halfway between 10 and 20. While idling, the engine would "stutter" and the line would drop down to TC


With the SPOUT in, it was idling @ 20
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3L timing? B-Poe 4-Cylinder Tech 15 06-29-2014 06:59 PM
Timing 87 2.9 v6 Yongintiger 2.9 Liter Tech 16 01-11-2012 08:57 PM
timing jaidacoleen Other Engine Tech 1 03-10-2011 05:28 PM
timing belt/cam timing issue omegatotal Drivetrain Tech 0 01-08-2011 02:18 PM
Timing belt or timing chain? Gonzos xlt 4-Cylinder Tech 8 09-27-2010 06:20 AM