Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-12-2011, 12:04 PM
needhelp needhelp is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 1
Default idle issue!

Any help will be greatly appreciated with my topic. I have a 1997 ford ranger 2.3L 5 speed manual that now stalls on me even on idle. It started a month ago when everytime I went fast and got off the throttle or when I was stopped at a stoplight it would stall on me. I have changed the plugs/wires, fuel filter and pump, timing was off as my tensionier spring was broke so it was replaced and now timing is fine. once stalled it sometimes will not start back up again for awhile. the erg pipe that goes down to my manifold was capped off before I bought so Im not sure if I should hook the pipe back up to the manifold? any help would be awesome thank you!

Josh
__________________
1997 ford ranger 2.3L 5 speed manual
Reply With Quote
  #2  
Old 06-12-2011, 02:28 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: idle issue!

Quote:
Originally Posted by needhelp View Post
Any help will be greatly appreciated with my topic. I have a 1997 ford ranger 2.3L 5 speed manual that now stalls on me even on idle. It started a month ago when everytime I went fast and got off the throttle or when I was stopped at a stoplight it would stall on me. I have changed the plugs/wires, fuel filter and pump, timing was off as my tensionier spring was broke so it was replaced and now timing is fine. once stalled it sometimes will not start back up again for awhile. the erg pipe that goes down to my manifold was capped off before I bought so Im not sure if I should hook the pipe back up to the manifold? any help would be awesome thank you!

Josh
first thing to do for DXing is to check for codes even pendng codes. next for idle issue you want to clean the TB, the IACV and the MAF. also makes sure the air filter is clean and the air intake is not clogged............I dont know much about the trucks once you start removing things ie. the EGR. but my guess is that it was running fine and then this issue started?.also I think you have a fuel pressure regulator on the fuel rail.....check the vacuum line and make sure there is no gas in it...

I see you are new here and I dont mean this as an insult but next time you have an issue try and DX it first...........did you do a fuel pressure test before swapping out the pump?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 06-12-2011 at 02:32 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
wierd little idle issue mehdi1993 3.0 Vulcan Tech 5 02-13-2012 07:30 PM
High Idle issue... Tigdim 3.0 Vulcan Tech 4 12-20-2010 12:28 AM
idle issue POPTART972 3.0 Vulcan Tech 9 11-15-2010 01:07 PM
96 ranger idle issue tiredtruckfixerupper 4.0 SOHC / 4.0 OHV Tech 1 10-17-2010 06:48 PM
2003 Ranger idle issue zorander6 General Tech 1 08-15-2010 09:22 AM