Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-09-2011, 08:25 PM
Rockslyde Rockslyde is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 29
Default Bad Altenator?

Okay so here's the scoop. Driving on my way to work the other day, the battery level which usually sits around half way, dipped down to a quarter. I got to work thinking maybe i snapped the belt or something, but everything seemed to be running fine. On my way home (1am, i am a bartender after all) I live about 25 miles from where i work, truck Seemed fine for a while, then about 13 miles from home the truck just dims slowly and loses all power to drive.

I knew instantly it was an electrical issue, shelled out way too much for towing, get her home, find out my voltometer is MIA. I check the altenator the only way i know how get the truck started, pull the positive terminal, she runs, but poorly i turn on the lights she dies. Do it again, this time just hitting the brakes dies.

Before i pull the alt, any one else have any ideas? (brand new battery, none of the fuses seem out of place, nothing that i can visiblely trace loose or missing to cause a short or drain)
__________________
1998 XLT 2WD
Reply With Quote
  #2  
Old 06-10-2011, 04:07 AM
TenSilver TenSilver is offline
The Old Man
 
Join Date: Sep 2010
Posts: 1,066
Default Re: Bad Altenator?

It sounds like your altenator went out. You sure did drive a good distance on a new battery before it drained though.

I like verifying with the multimeter first but yours is missing. If the altenator is easy to pull I would just take it out and go to an auto parts store to verify it is dead before buying a new one.
__________________
2010 Silver Ford Ranger XLT 2.3L 2WD StyleSide Reg Cab Auto, Open 7.5" - 4.10 diff.
TruxEdo tonneua cover, rubber bed mat, Ranger all weather floor mats.

Last edited by TenSilver; 06-10-2011 at 04:10 AM.
Reply With Quote
  #3  
Old 06-10-2011, 04:59 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Bad Altenator?

Don't disconnect the battery with the truck running anymore.

Was the battery light on? Also, when you put the key in and turn it to on, does the airbag light come on for a few seconds?
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #4  
Old 06-10-2011, 05:36 AM
Rockslyde Rockslyde is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 29
Default Re: Bad Altenator?

Battery light never went on, but i've had it happen in the past where the altenator went and that light didn't come on. as for the airbag light, that always comes on when i start it.
__________________
1998 XLT 2WD
Reply With Quote
  #5  
Old 06-10-2011, 06:46 AM
dvrich dvrich is offline
Lifetime DAV Member
 
Join Date: Sep 2010
Posts: 2,438
Default Re: Bad Altenator?

Did you check the actual DC voltage with the engine running and with the engine off? That would be the first thing you should do........ besides running down to auto zone and having the battery load tested.
__________________
2014 Ford F150 4x4 Supercab 5.0 STX 9500 miles 18 mpg overall
2015 Ford F150 4x2 Supercab 3.5 TIVCT 13,500 miles 21 mpg overall
Reply With Quote
  #6  
Old 06-10-2011, 07:28 AM
Rockslyde Rockslyde is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 29
Default Re: Bad Altenator?

I don't have a multimeter at the moment to try it that way, and i can't just run down to a parts store or dealership, as the nearest one is about 23 miles away. Yay farm life...
__________________
1998 XLT 2WD
Reply With Quote
  #7  
Old 06-10-2011, 07:48 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: Bad Altenator?

Well those are you're two options. Best I can suggest is charging the battery overnight with a battery charger and hoping you make it all the way to town on the charge. Or, have a friend drive you?

The reason I ask about the airbag light is because it is on the same fuse as the battery light. And the battery light circuit is also what provides field current to the alternator in order for it to start generating power. If that fuse is blown, you won't get an airbag light, you won't get a battery light, and the alternator will not work at all.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #8  
Old 06-10-2011, 08:42 PM
Rockslyde Rockslyde is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 29
Default Re: Bad Altenator?

Charged the battery up, truck started fine. then same kinda thing happened. I did notice however though, that i don't have a battery light at all, not when i put the key in and turn it, not when it dies, nothing at all, though the Airbag light does still come on. I'm thinking now that it's the alt for sure. Gonna pull it on sunday, have em load test it monday ish
__________________
1998 XLT 2WD
Reply With Quote
  #9  
Old 06-12-2011, 06:57 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Actually, look at the alternator and see if there is a wire fallen off. If that wire for the light fell off, your alternator will never be able to start generating power.

[Posted with my Android mobile device using Tapatalk Pro]
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #10  
Old 06-12-2011, 07:04 AM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: Bad Altenator?

im seeing more and more threads about alternators...just for my own info...where is an alternator in my truck?
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #11  
Old 06-12-2011, 07:05 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Quote:
Originally Posted by HazardousRanger View Post
im seeing more and more threads about alternators...just for my own info...where is an alternator in my truck?
It's the thing on the front that looks like an alternator and has wires coming off of it.

[Posted with my Android mobile device using Tapatalk Pro]
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #12  
Old 06-12-2011, 07:09 AM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: Bad Altenator?

haha idk what an alternator looks like but the wires will point it out thanks
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #13  
Old 06-12-2011, 08:50 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Google?

[Posted with my Android mobile device using Tapatalk Pro]
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #14  
Old 06-12-2011, 11:04 AM
TomN TomN is offline
<-----Needs moar liftz
 
Join Date: Jun 2010
Posts: 1,125
Default Re: Bad Altenator?

__________________
1997 Ranger XLT
4.0 4X4 Lotta Mods.

2001 Ford Crown Victoria Police Interceptor. 4.6 V8

Quote:
Originally Posted by richarddhoward View Post
my truck will rape your Honda.
Reply With Quote
  #15  
Old 06-12-2011, 11:16 AM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: Bad Altenator?

haha ^ thanks
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad timing chain cassette/tensioner cause bad gas mileage? xDARKGUITARISTx 4.0 SOHC / 4.0 OHV Tech 10 09-18-2012 01:47 PM
Is this bad? Scott3483 Vehicle Snapshots 7 01-05-2011 06:09 AM
Craigslist / eBay Find: Not bad at all brett20 Trucks 2 12-23-2010 11:48 AM
need help bad macdaddy08 Lifted Suspension 11 10-27-2010 08:19 PM
Need help bad 90onDubz 2.9 Liter Tech 6 12-07-2009 09:49 PM