Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-28-2011, 11:01 PM
redranger94 redranger94 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 3
Question What to fix first

I have a 94 Ranger 2.3

I pulled the following codes: 15,39,53,91,22,42,24. What should I fix first?

I read the description for the codes and t seems like 91 and 42 might be related? (o2 sensor).

Any help will be greatly appreciated.
__________________
1994 Ranger 2.3
Reply With Quote
  #2  
Old 05-28-2011, 11:05 PM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: What to fix first

what do the codes mean, tel us that first and then we can tell u
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #3  
Old 05-28-2011, 11:11 PM
redranger94 redranger94 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 3
Default Re: What to fix first

Thanks. Sorry about that. Here's what I found online on those codes:

15 (O) No Keep Alive Memory power to PCM pin 1 or bad PCM (Memory Test Failure)

39 Transmission Torque Converter clutch not engaging

53 Throttle Position sensor too high

91 (R, M) System running lean

42 (R) System rich

24 Intake Air Temperature (IAT) or Vane Air Temperature (VAT) sensor out of range
__________________
1994 Ranger 2.3
Reply With Quote
  #4  
Old 05-28-2011, 11:14 PM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: What to fix first

i would fix 24 first, could possinly fix another problem...could be wrong though but anyway

----------

thats what id do
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #5  
Old 07-20-2011, 09:57 PM
redranger94 redranger94 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 3
Default Re: What to fix first

Here's an update to this old thread, but I thought it might be useful to others what I learned when trying to fix my engine light as well as to ask another question.

First, what I learned:
I found out that reading codes using the engine light is tricky and in fact, the codes I read I interpreted incorrectly.

When I got the codes by counting engine light flashes I thought I read: 15,39,53,91,22,42,24

The codes I got using a code reader were:
539, 539, 10, 224, 224

It turns out that the Ford computer sends the codes twice, and it uses a 10 to separate between hard codes and stored codes. **It is really hard to count a 0**

Of all these codes the only one that was important was the 224, which I fixed by replacing the ICM. Engine light went away and truck has been running great.

Second: My new question

The other morning the truck simply refused to start. It cranked normally but it just did not start. When trying to see if it had a spark, I removed one of the spark plug cables to plug an ignition tester (to see the spark), tried cranking to see the spark and sure enough there was a spark and the truck started ...

Any idea what could have caused the no start?

Thank you
__________________
1994 Ranger 2.3
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone know how to fix this? tom56 General Tech 5 12-21-2010 04:20 PM
If I can fix it I will keep it! johnfrankdavis Introduce Yourself 12 12-01-2010 06:12 PM
Well that didn't fix it mhtranger 4.0 SOHC / 4.0 OHV Tech 1 11-15-2010 09:12 PM
Need a fix! Help me with this. Z Ranger Wheels and Tires 21 11-01-2010 09:25 AM
What can I do to fix this? snakeranger Exterior Tech 13 04-08-2010 03:50 PM