Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-21-2011, 08:36 AM
Mack91 Mack91 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 6
Default A/C Doesn't Run at idle

For some reason, my 95 4CLY 4WD doesn't run its air conditioning while it's idling. Stoplights suck pretty bad currently. I have no idea why this would be.. The compressor cuts on, but cuts off right after. It runs cold when I'm driving..

Any ideas? Thanks!
Reply With Quote
  #2  
Old 05-21-2011, 06:14 PM
zipsayain zipsayain is offline
Ford Truck Driver
 
Join Date: Apr 2011
Posts: 76
Default Re: A/C Doesn't Run at idle

Mine does it to, if stop for too long.
Reply With Quote
  #3  
Old 05-21-2011, 06:22 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: A/C Doesn't Run at idle

I bet something is wrong with your fan. When you're moving, air is moving through the grill. When you stop, without a working fan, no air through the grill equals no AC.

When you're stopped, if you step on the gas to bring the RPM up, does the problem remain?
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #4  
Old 05-22-2011, 07:11 AM
Mack91 Mack91 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 6
Default Re: A/C Doesn't Run at idle

Quote:
Originally Posted by FireRanger View Post
I bet something is wrong with your fan. When you're moving, air is moving through the grill. When you stop, without a working fan, no air through the grill equals no AC.

When you're stopped, if you step on the gas to bring the RPM up, does the problem remain?
Yeah, but I have an electric fan wired to the truck. It runs while I'm stopped anyway.

The RPM's while stopped haven't really made an impact that I can tell.

It's like the truck just cuts it off while it's idling... My Hayne's manual is no help to this of course.
Reply With Quote
  #5  
Old 05-22-2011, 07:43 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: A/C Doesn't Run at idle

That makes me suspect the fan even more. Next time you stop and the AC quits, open the window or get out and look/listen. I bet the fan won't be moving. The reason I suspect this is because you're saying that bringing the RPM up while stopped doesn't change it.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #6  
Old 05-24-2011, 06:05 PM
Mack91 Mack91 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 6
Default Re: A/C Doesn't Run at idle

Thanks I'll look into that. I really have no idea how it is wired.. PO work. haha
Reply With Quote
  #7  
Old 06-05-2011, 01:36 PM
PureCountry95 PureCountry95 is offline
Like the Forums
 
Join Date: Sep 2010
Posts: 44
Default Re: A/C Doesn't Run at idle

I have this same problem. It runs cold when driving, but when stopped at a light, not on the gas, the air gets hot. (I do not have an RPM Gauge)
__________________
1995 Ford Ranger - Blue
Standard, 2.3L, 4CYL, 2WD, XLT
No Mods.
Reply With Quote
  #8  
Old 06-05-2011, 07:07 PM
Rg1Baja Rg1Baja is offline
DirtFreeks Mtrspts #7299
 
Join Date: May 2011
Posts: 180
Default Re: A/C Doesn't Run at idle

Check the a/c pressures?
Reply With Quote
  #9  
Old 07-31-2011, 06:17 AM
bubonic0 bubonic0 is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 1
Default Re: A/C Doesn't Run at idle

I'm having the same problem, and was told it is the cycling switch on the low pressure side...Replaced it and it seems worse than ever. Now the a/c clutch is kicking out sometimes even while driving at higher rpm than idling. It's an old 96 XLT 2.3 liter 4x4 with 197,000 miles.
Thanks for any help guys.
Reply With Quote
  #10  
Old 08-02-2011, 08:24 AM
killj0y killj0y is offline
Ford Tough
 
Join Date: Jun 2011
Posts: 478
Default Re: A/C Doesn't Run at idle

low suction/pressure in the system probably
Reply With Quote
  #11  
Old 08-02-2011, 08:47 AM
dregiste1 dregiste1 is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 9
Default Re: A/C Doesn't Run at idle

I'm having the same problem. Anytime I'm in idle the compressor shuts off, but as soon as I give it some gas the compressor kicks on. My father in law thinks it's a vacuum leak. Since it only does it in idle, and the idle is a little rough anyway, he thinks the cpu is telling the compressor to stay off because it's not running at a high enough rpm. Can a vacuum leak cause this issue? We've sprayed 2 1/2 cans of carb cleaner on the motor looking for a leak and can't find one.
__________________
97 XLT Extended Cab
Roll Tide!
Reply With Quote
  #12  
Old 08-04-2011, 02:51 PM
dvrich dvrich is offline
Lifetime DAV Member
 
Join Date: Sep 2010
Posts: 2,437
Default Re: A/C Doesn't Run at idle

Quote:
Originally Posted by FireRanger View Post
That makes me suspect the fan even more. Next time you stop and the AC quits, open the window or get out and look/listen. I bet the fan won't be moving. The reason I suspect this is because you're saying that bringing the RPM up while stopped doesn't change it.

Could be the compressor clutch sticking. Before I replaced one on my 89 a long time ago the only way I could get the clutch to engage was to race the engine briefly. Or maybe the electric fan is not pulling enough air through the coils.
__________________
2014 Ford F150 4x4 Supercab 5.0 STX 9500 miles 18 mpg overall
2015 Ford F150 4x2 Supercab 3.5 TIVCT 13,500 miles 21 mpg overall
Reply With Quote
  #13  
Old 08-04-2011, 05:48 PM
Mack91 Mack91 is offline
Learning to use the forums
 
Join Date: May 2011
Posts: 6
Default Re: A/C Doesn't Run at idle

I'm still not sure what the issue is. I'm thinking that the system needs to be pulled down and charged. That's what my mechanic said is the likely cause. I'll post if I fix it.
Reply With Quote
  #14  
Old 08-04-2011, 06:52 PM
vishous vishous is offline
Ford Ranger Owner
 
Join Date: Aug 2011
Posts: 50
Default Re: A/C Doesn't Run at idle

sounds like low pressure, when u drive it builds higher pressure and when stopped u loose it. make sure system is full
__________________
1996 ranger with 2003 splash bed and 2010 front clip. Fully bagged and layed out. 4 link rear suspension . 18" wheels and alot more to do. Going to welding shop to get shaved up nice and clean.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle, hunting idle under way, assistance requested Doctor Wily 4-Cylinder Tech 8 10-07-2016 12:13 PM
Need Help won't run right until warm trshmn 4-Cylinder Tech 5 03-28-2011 04:30 PM
Won't run!!!! robbiecox6 4.0 SOHC / 4.0 OHV Tech 2 02-27-2011 09:45 AM
can i run these? Ranger Girl Wheels and Tires 21 12-11-2010 10:05 AM
can someone run me a carfax? MattFetters Off Topic 1 01-21-2010 07:50 PM