Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-28-2011, 11:35 PM
Guest Guest is offline
Been there, done that!
 
Join Date: Apr 2011
Posts: 37
Default '94 2.3 with bad mis and heavy pinging

Hey all,
Just wondering if there is any one thing that I should be looking at on this 2.3. It has a bad mis, and anytime its under a load it pings really badly.
I just picked this truck up the other day, so I haven't had time to do my own compression test, but the PO stated that one of the cylinders was low, and all increased about 10 - 15 psi when wet tested. (about normal)

Anyway, the engine doesn't smoke, or knock, and other than the pinging, and the mis, it sounds really good.

I'll be pulling the head over the weekend if I can find the time, but I was hoping someone might know what I should expect to find.

Thanks for any input.
__________________
Rangers, '95, 2.3, '98 2.5, 4x2 extra cab's, '96, 2.3 base model, '99, Mazda B3000.
Reply With Quote
  #2  
Old 04-29-2011, 04:46 AM
ddunfee ddunfee is offline
Ford Motor Co
 
Join Date: Jan 2011
Posts: 169
Default Re: '94 2.3 with bad mis and heavy pinging

Does it show any codes?
Reply With Quote
  #3  
Old 04-29-2011, 10:36 AM
Guest Guest is offline
Been there, done that!
 
Join Date: Apr 2011
Posts: 37
Default Re: '94 2.3 with bad mis and heavy pinging

To be honest, I haven't checked. The truck is being delivered today, so I'll pull the codes when it arrives. I did learn that the PO replaced the TPS, whether or not that was adjusted correct is unknown.

Thanks.
__________________
Rangers, '95, 2.3, '98 2.5, 4x2 extra cab's, '96, 2.3 base model, '99, Mazda B3000.

Last edited by Guest; 04-30-2011 at 09:58 PM.
Reply With Quote
  #4  
Old 04-30-2011, 10:06 PM
Guest Guest is offline
Been there, done that!
 
Join Date: Apr 2011
Posts: 37
Default Re: '94 2.3 with bad mis and heavy pinging

Update.

Pulled the head and was quite surprised at what I found. The #3 exhaust valve seat had come loose from the head and was caught between the valve and the port. I have never seen this before, it this common on Ford engines? Anyone ever have, or seen this happen?

Not only was the valve seat dislodged, but the head gasket was burned out between #'s 3 & 4, leaving only 2 cylinders working. Its hard to believe the engine ran at all.

I think I may have lucked out on this one because I just happen to have another head ready to go.

I'll be back with another update on this project next week.
__________________
Rangers, '95, 2.3, '98 2.5, 4x2 extra cab's, '96, 2.3 base model, '99, Mazda B3000.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is what I hear pinging danray35e 3.0 Vulcan Tech 15 03-28-2015 06:58 PM
Engine pinging at light load MOOREMNY 4-Cylinder Tech 4 02-09-2011 10:55 PM
Pinging DieselBrad 4.0 SOHC / 4.0 OHV Tech 9 09-06-2010 05:19 PM
mis FX4 4.0 SOHC / 4.0 OHV Tech 9 12-21-2009 07:13 AM
4.0 Cyl Pinging or Timing Chain Rattle? jdh02b 4.0 SOHC / 4.0 OHV Tech 5 11-19-2009 03:07 PM