Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-08-2011, 08:36 PM
Doctor Wily Doctor Wily is offline
Science!
 
Join Date: Feb 2011
Posts: 356
Default rough idle, hunting idle under way, assistance requested

Good day everyone!

So I've decided to start a thread on an issue that I have been having and that I plan to fix in the next 4 weeks (before the semester is over.)

Since I got the truck a couple months ago the main issue I have been trying to fix and troubleshoot is the poor idle I have. If I start the truck first thing in the morning and go about my trip to class or work, after about 2 miles of driving (or less sometimes) i have to stop at a light. as i sit at the light the engine has what seems to be a high idle, then it drops down a bit, then it drops even more and sputters and misses and sound like it is going to completely die. It never does and if I give it a little throttle it will even out until i let off and it bogs down again. So far we have checked the MAF, cleaned it and it's good, we have cleaned the throttle body due to coking, cleaned the IAC thru the throttle body, checked the O2 sensor using a oscilloscope and found it reading a bit lean. This was due to an exhaust leak and that has been repaired. The scanner indicates the truck short term fuel trim is 15 - 33% higher depending on load so the truck is actually running rich. I replaced the air filter as well since it needed to be done.

I am looking for a few suggestions on what to look at next. I plan to do a compression test monday in my class and may try and do plugs too. If I find discrepancies in the compression test i'll do a leak down and see what's going on.

Any other suggestions? thanks!
__________________
Current: 2000 Ford Explorer XLS 4x4 Automatic 4.0L SOHC

Gone but not forgotten ~ "Ghetto Blue" my 1994 Mazda B2300 5 Speed Standard Cab 4x2.
Reply With Quote
  #2  
Old 04-12-2011, 01:00 PM
Bomilcar Bomilcar is offline
Liking the Ford Ranger Forum
 
Join Date: Jan 2011
Posts: 20
Default Re: rough idle, hunting idle under way, assistance requested

How did it all come out?

---The reason i ask is because my 87 does the exact same thing and its driving me crazy trying to track down the culprit!!!
Reply With Quote
  #3  
Old 04-12-2011, 02:24 PM
Doctor Wily Doctor Wily is offline
Science!
 
Join Date: Feb 2011
Posts: 356
Default Re: rough idle, hunting idle under way, assistance requested

Its done it since I got the truck a couple months ago. Did 4 plugs yesterday. Plugs showed signs of lean condition. Going to start searching for a vacuum leak.
__________________
Current: 2000 Ford Explorer XLS 4x4 Automatic 4.0L SOHC

Gone but not forgotten ~ "Ghetto Blue" my 1994 Mazda B2300 5 Speed Standard Cab 4x2.
Reply With Quote
  #4  
Old 04-12-2011, 06:01 PM
trshmn trshmn is offline
Like the Forums
 
Join Date: Mar 2011
Posts: 32
Default Re: rough idle, hunting idle under way, assistance requested

Mine does same thing when it's cold, after it warms up runs like a champ, driving me nuts, got new plugs & wires, TPS, IAC, CTS, cleaned MAF with carb cleaner, and cleaned throttle body, run a can of sea foam thru tank of gas, if anybody has any other ideas please let me know
__________________
1997 Ranger XLT reg. cab, 2wd, 2.3 4cly, 5 speed spark plug mod.
Reply With Quote
  #5  
Old 04-12-2011, 08:35 PM
Gumcrew2 Gumcrew2 is offline
Ford Tough
 
Join Date: Feb 2011
Posts: 287
Default Re: rough idle, hunting idle under way, assistance requested

Quote:
Originally Posted by trshmn View Post
Mine does same thing when it's cold, after it warms up runs like a champ, driving me nuts, got new plugs & wires, TPS, IAC, CTS, cleaned MAF with carb cleaner, and cleaned throttle body, run a can of sea foam thru tank of gas, if anybody has any other ideas please let me know
Mine does too!!

rebuilt motor! new coil, wires, plugs, cap, rotor, everything.

When it's cold, until the block is at temp (according to working temp gauge) it won't idle well and run's like a dog. When it's uber cold (-20* or colder) I have to hold my foot at idle 1/4" on the pedal for a good 3 minutes to maintain idle without stalling. No resolution, it's an old carter YFA carb, o well
__________________
'83 Ford Ranger 2.3L 4Spd, Dual Tanks, 195/60R15's, Welded Rear End TOTALLED AT 483,211 MILES
Reply With Quote
  #6  
Old 04-13-2011, 11:52 AM
Bomilcar Bomilcar is offline
Liking the Ford Ranger Forum
 
Join Date: Jan 2011
Posts: 20
Default Re: rough idle, hunting idle under way, assistance requested

Seems like you guys are having this issue at cold idles whereas the situation with my truck is at WARM IDLE. Hmmmmmm


I have read on here that the 87s puter doesnt start to read from its sensors until it hits a certain temp, going off of that info, i can only conclude that I am missing a bad sensor on my end somewhere.

I am aware we all seem to have different year models, so there are slight differences. If your model year is the like my 87, then maybe there is a mechanical problem instead of an electrical one. Like maybe your fuel pump is going or your fuel filter is clogged.
Mya not help, but just a thought.
__________________
1997 Ford Ranger XL 2wd Reg Cab
2.3L 4 cly 57,010 original miles
=============
1987 Ford Ranger XLT 2wd Reg Cab
2.3L 4 cyl 250xxx miles
Reply With Quote
  #7  
Old 07-08-2012, 06:35 PM
JerryK JerryK is offline
Learning to use the forums
 
Join Date: Sep 2011
Posts: 3
Default Re: rough idle, hunting idle under way, assistance requested

Hello everyone,

I know this is a old thread but I am having the same problem.

At idle my truck barely seems like it is going to stay running below 1000rpm, when i am driving and put the clutch in it will rev up to 2200rpms then back down to 1000rpm then lower like it is getting ready to stall, i have cleaned the IAC, replaced both o2 sensors still doing the same thing, the check engine light came on went to a auto parts store and the computer said it was precat o2 sensor replaced that still no change, went to another auto parts store there computer said the precat o2 sensor was bad, I told them I just replaced it yesterday so they suggested replace the postcat o2 sensor still idles the same way, when driving the truck runs great. I am thinking of just replacing the IAC and see what happens.
Thanks
__________________
2003 Ranger XL, 2.3 liter DOHC, 2WD, 5spd.
No modifications.
Reply With Quote
  #8  
Old 10-13-2012, 04:33 PM
Mudrat26 Mudrat26 is offline
Learning to use the forums
 
Join Date: Sep 2012
Posts: 7
Default Re: rough idle, hunting idle under way, assistance requested

did you get this resolved?
Reply With Quote
  #9  
Old 10-07-2016, 01:13 PM
zolar1 zolar1 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2014
Posts: 16
Default Re: rough idle, hunting idle under way, assistance requested

Quote:
Originally Posted by trshmn View Post
Mine does same thing when it's cold, after it warms up runs like a champ, driving me nuts, got new plugs & wires, TPS, IAC, CTS, cleaned MAF with carb cleaner, and cleaned throttle body, run a can of sea foam thru tank of gas, if anybody has any other ideas please let me know
Your purge valve and vent valve for the evap system might be the problem.

Here is a picture of my canister vent valve leasking:
Note: it is not fully fix my rough idle problem when I disconnected the purge valve vacuum line under the hood and plugged off the vacuum port on the intake. But it did help.

see picture:
Attached Images
File Type: jpg Cannister leak?.jpg (93.0 KB, 2 views)
__________________
Computers are like air conditioners - they quit working when you open windows....
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE Chargerondavins 3.0 Vulcan Tech 1 03-26-2011 05:54 PM
rough idle '94 Shane17 4-Cylinder Tech 0 03-03-2011 02:04 PM
rough idle 01motomike 3.0 Vulcan Tech 6 02-26-2011 11:32 AM
Rough Idle Please Help tilley101 4.0 SOHC / 4.0 OHV Tech 3 11-12-2010 01:25 PM
Rough Idle Jimmyboiii 4-Cylinder Tech 5 08-24-2009 06:01 AM