Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 04-03-2011, 07:21 PM
slamed 89 ranger slamed 89 ranger is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 8
Default having trouble idleing

hello i am new to this site ok my prob is my truck just started this today when you crank it up it idles then it changes to sounding like a huge cam is in it . when i unplug the vac line from the map sensor it still sounds like a cam but revs good but when you plug it back up it starts to die a jerks an shakes an dies . as i try to start it back up it dosnt want to start an stay runnin with the vac line hooked up i need help thanks for your time an advice

----------

i have tryed 3 diffrent map sensors on it . it has new o2 sensor , map sensor ,new fuel pump, filter, relays cant figure this out . i am prob forgetting something
Reply With Quote
  #2  
Old 04-03-2011, 08:33 PM
WildlandFirefighter WildlandFirefighter is offline
Blut und Ehre
 
Join Date: Dec 2010
Posts: 394
Default Re: having trouble idleing

Maybe the timing...mine is doin the same thing....got to adjust my timing.
__________________
1979 Ford F150 4X4, 7.5L, C6, 38s Super Swampers TSL

1978 Ford Courier 4x4, 2.3L carbed, 5 spd manual, dry-rotted tires

1985 Ford Ranger 4x4, 2.3L FI, 5 spd manual, 29s Power Kings

1990 Ford Bronco 4x4, 4.9L, 5 spd manual, 31s Maxxis Bighorns
Reply With Quote
  #3  
Old 06-27-2012, 07:08 PM
slamed 89 ranger slamed 89 ranger is offline
Learning to use the forums
 
Join Date: Apr 2011
Posts: 8
Default

Mine did this once i changed the idle air an the map ran all new mac lines
__________________
just another p.o.s
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Surging While Idleing. SmokeyMcPot420 3.0 Vulcan Tech 12 06-01-2012 10:28 AM
Trouble with brakes dragging? Trouble engaging clutch! 96DangerRanger Drivetrain Tech 2 08-16-2011 02:05 PM
4.0l trouble bfeltner99 4.0 SOHC / 4.0 OHV Tech 1 02-17-2011 05:06 AM
96 ranger idleing problem 96_ranger 4-Cylinder Tech 1 07-08-2010 02:42 PM
having some trouble 94ranger3.0 3.0 Vulcan Tech 21 12-22-2009 08:46 PM