Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-25-2011, 01:45 PM
Red97Ranger Red97Ranger is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 4
Default New parts and engine wont start

I am new to this site and hoping someone can shed some light on my problem. I have a 97 2.3L 5 speed ranger. It died on me. Long story short the timing belt broke.

Tore it down replaced the timing belt, lined up the crankshaft key at 12:00, oil pump shaft (diamond to diamond) and the camshaft (triangle to triangle). Camshafts about half a tooth off. I also replaced the camshaft sensor, crankshaft sensor and the throttle position sensor.
Cleared the code for the camshaft sensor. Went to turn it over and it didn't start. I checked spark it was good, the plugs are soaked in gas (so I believe itís getting fuel), and compression is good. I also checked the fuel shut off switch (inside cab on passengers side under glove box) all seams good.

About 10,000 miles ago I put in a new fuel pump.

I have run out of ideas.
__________________
97 Ranger 2.3L Manual 2x4
Reply With Quote
  #2  
Old 03-25-2011, 02:00 PM
MoundLiferanger204 MoundLiferanger204 is offline
Liking the Ford Ranger Forum
 
Join Date: Feb 2011
Posts: 16
Default Re: New parts and engine wont start

did u bring the #1 cylinder to TDC i used a broken plug wire to feel when it came to the top an had an extra set of hands spin the crank nut, even with the timing belt half way on there i had to adjust mine but its a 2.5 so it should be pretty close
Reply With Quote
  #3  
Old 03-25-2011, 05:12 PM
Gumcrew2 Gumcrew2 is offline
Ford Tough
 
Join Date: Feb 2011
Posts: 287
Default Re: New parts and engine wont start

Are you sure it was on the compression stroke not the exhaust stroke even if it was at TDC?

I stick my finger in the spark plug hole while turning the crank to verify positive pressure (compression stroke)
__________________
'83 Ford Ranger 2.3L 4Spd, Dual Tanks, 195/60R15's, Welded Rear End TOTALLED AT 483,211 MILES
Reply With Quote
  #4  
Old 03-25-2011, 11:30 PM
Red97Ranger Red97Ranger is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 4
Default Re: New parts and engine wont start

Well I got it running. I went through and unplugged a bunch of connectors and reconnected them. So I must have bumped something.
__________________
97 Ranger 2.3L Manual 2x4
Reply With Quote
  #5  
Old 03-26-2011, 11:51 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: New parts and engine wont start

Quote:
Originally Posted by Red97Ranger View Post
Well I got it running. I went through and unplugged a bunch of connectors and reconnected them. So I must have bumped something.
I would have guessed that the Cam needed to be spun 180 degrees,,,,,,,but you got it running.....so I guess I would have been wrong
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a 92 ford ranger pickup w/2.3L engine. Problem is it wont start using the steinerrw 4-Cylinder Tech 4 09-29-2013 08:52 PM
Wont start, Wont turn over, no clicking, no lights, Battery is good JustinMilo Electrical Tech 5 06-14-2011 09:01 AM
engine turns but wont start vzmaradona 4-Cylinder Tech 4 12-04-2010 11:02 PM
2.9 wont start THETROOPER 2.9 Liter Tech 6 09-21-2010 11:16 AM
Truck still wont start all new ignition parts rumpranger 4-Cylinder Tech 0 01-04-2010 04:24 PM