Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-20-2011, 10:53 AM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default 2.3 not firing

I got this truck from my father in law and it wont fire
heres the run down.
1990 2.3 ranger 4x4 1996 2.3 motor installed , standard shift.
ran fine and just quit 1 day no fire,
New owner ME

poppy in law said he had a new key switch installed and new crank sensor

I had autozone check both coil packs, good
checked DIS ignition module, good

all fuses good

Any and all help is greatly appreciated this truck must run due to high gas prices of bigger brother 06 F150 supercab better known as GASHOG
Reply With Quote
  #2  
Old 03-20-2011, 03:59 PM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

Anyone out there????????
Reply With Quote
  #3  
Old 03-20-2011, 04:02 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: 2.3 not firing

Sorry sometimes threads slip through. Anyways Does it crank? And you are for sure throwing spark? Fuel pump working?
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #4  
Old 03-20-2011, 05:41 PM
sbristow84 sbristow84 is offline
Ford Rangers
 
Join Date: Dec 2010
Posts: 208
Default Re: 2.3 not firing

sounds like the same problem that I am having with my 1994 2.3l
__________________
1997 Eddie Bauer Explorer: JVC Double din deck with navi, 2 - Rockford 12" T2's, 1 Kicker 1500.1 mono block amp, 1 kicker 650.4-4 channel amp, 4 Boston pro door speakers, Wade in-channel visors, 15x7 wheels wrapped in 31x10.5x15 Falken Rough Country tires. Torsion crank, custom 2.5 inch rear shackles, Aftermarket taillights, 8k HID headlights, 8K Fog Lights, 8k Hella 500's, alarm chirp button, and a Viper 5901 alarm with remote start to protect it all. I got one loud ass truck.
Reply With Quote
  #5  
Old 03-21-2011, 09:11 AM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

It is cranking and getting fuel, no spark
Reply With Quote
  #6  
Old 03-21-2011, 10:25 AM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: 2.3 not firing

Have you replaced your plugs and wires?
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #7  
Old 03-21-2011, 04:37 PM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

my father in law said he did
Reply With Quote
  #8  
Old 03-21-2011, 04:38 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: 2.3 not firing

What about your coil pack?
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #9  
Old 03-21-2011, 04:56 PM
WildlandFirefighter WildlandFirefighter is offline
Blut und Ehre
 
Join Date: Dec 2010
Posts: 394
Default Re: 2.3 not firing

Check your timing belt. It sometimes jumps a notch and won't let it fire because it's off time.
__________________
1979 Ford F150 4X4, 7.5L, C6, 38s Super Swampers TSL

1978 Ford Courier 4x4, 2.3L carbed, 5 spd manual, dry-rotted tires

1985 Ford Ranger 4x4, 2.3L FI, 5 spd manual, 29s Power Kings

1990 Ford Bronco 4x4, 4.9L, 5 spd manual, 31s Maxxis Bighorns
Reply With Quote
  #10  
Old 03-22-2011, 10:03 AM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

It is in time I believe I have electrical gremlin
Wiring Harness HELP
Reply With Quote
  #11  
Old 03-23-2011, 02:49 PM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

Wiring Harness HELP
Reply With Quote
  #12  
Old 03-27-2011, 12:55 PM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

I bought a 91 2 wd doner truck to fix this problem
was gonna work on it today but its cold and snowing
Reply With Quote
  #13  
Old 04-03-2011, 05:59 PM
Lowell Lowell is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 14
Default Re: 2.3 not firing

switched computer harness problem fixed
thanks
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine crancks over but not firing cobrex 3.0 Vulcan Tech 14 11-07-2011 04:03 PM
2.3l not firing on 2 cylinders murry General Tech 3 11-26-2010 08:25 PM
Which Firing Order???? RedFord 4-Cylinder Tech 0 11-04-2010 09:21 AM
Need firing order for four cylinder vanhoopcoach 4-Cylinder Tech 6 09-14-2010 07:49 PM
miss firing 4.0ltr need help Banger91 4.0 SOHC / 4.0 OHV Tech 0 06-06-2010 04:08 PM