Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 03-18-2011, 09:45 PM
Darthwillie Darthwillie is offline
Learning to use the forums
 
Join Date: Mar 2011
Posts: 4
Default 2.3 won't start, gas flooding or crank sensor?

My Ranger motor flood with gas i think, bcus of the smell of gas when i try to start the motor. I check the inertia switch and is fine, but, if i disconnect the cable plug of the inertia switch and try to crank the motor, it's start until instantly die (i know, is bcus still disconneted) but when i plug it again and crank now start with some problems until die again. The motor start ONLY if i do the previous mentioned in the same order, unplug inertia switch, crank the motor for run and instant die, plug it again, crank it and the motor run for like 3 minutes until die. The Ranger never show any problem at all until the timing belt was broken, i have to center the crank sensor bcus the belt move the sensor when broke, motor don't start for the sensor position problem and when i align the sensor it's turn on, i never replace the sensor, still running with the same old one. After the alignment of the sensor the Ranger run for about 1 week, and now is with the gas flooding problem (not sure). A bad crank sensor have something to do with the fuel pump?. Spark plug cable are new and have a strong spark.

ps: Thanks for your help.

Best regards.
Willie
Reply With Quote
  #2  
Old 04-23-2013, 02:54 PM
dannmu64 dannmu64 is offline
Learning to use the forums
 
Join Date: Apr 2013
Posts: 7
Default Re: 2.3 won't start, gas flooding or crank sensor?

I have the same problem with my 3.0 V6. What did u find out about yours?
__________________
2000 Ford Ranger XLT 4x4
3.0 L super cab
Reply With Quote
  #3  
Old 04-23-2013, 02:59 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by Darthwillie View Post
My Ranger motor flood with gas i think, bcus of the smell of gas when i try to start the motor. I check the inertia switch and is fine, but, if i disconnect the cable plug of the inertia switch and try to crank the motor, it's start until instantly die (i know, is bcus still disconneted) but when i plug it again and crank now start with some problems until die again. The motor start ONLY if i do the previous mentioned in the same order, unplug inertia switch, crank the motor for run and instant die, plug it again, crank it and the motor run for like 3 minutes until die. The Ranger never show any problem at all until the timing belt was broken, i have to center the crank sensor bcus the belt move the sensor when broke, motor don't start for the sensor position problem and when i align the sensor it's turn on, i never replace the sensor, still running with the same old one. After the alignment of the sensor the Ranger run for about 1 week, and now is with the gas flooding problem (not sure). A bad crank sensor have something to do with the fuel pump?. Spark plug cable are new and have a strong spark.

ps: Thanks for your help.

Best regards.
Willie
if its flooded unplug the switch and crank it for a bit to try and blow the gas put I would start with that
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #4  
Old 04-23-2013, 03:03 PM
dannmu64 dannmu64 is offline
Learning to use the forums
 
Join Date: Apr 2013
Posts: 7
Default Re: 2.3 won't start, gas flooding or crank sensor?

I have done that, switched off the fuel pump switch, tried it, turned switch back on, then it will crank, then finally start, run rough, backfire some, die. Check the plugs and flooded again. Then wont start again. Getting spark, air, and fuel. My injectors are staying open and not pulsing
__________________
2000 Ford Ranger XLT 4x4
3.0 L super cab
Reply With Quote
  #5  
Old 04-23-2013, 03:04 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by dannmu64 View Post
I have done that, switched off the fuel pump switch, tried it, turned switch back on, then it will crank, then finally start, run rough, backfire some, die. Check the plugs and flooded again. Then wont start again. Getting spark, air, and fuel. My injectors are staying open and not pulsing
then something is up with your computer
Or your injectors are bad
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #6  
Old 04-23-2013, 03:07 PM
dannmu64 dannmu64 is offline
Learning to use the forums
 
Join Date: Apr 2013
Posts: 7
Default Re: 2.3 won't start, gas flooding or crank sensor?

Ok, I just got a used computer, pulled out the old one, visually looked fine. Had to deal with the anti-theft thing with the chip in the key. I have the plugs out and letting it dry out some. If this doesn't fix the problem do u think I could have a wiring issue with the computer?
__________________
2000 Ford Ranger XLT 4x4
3.0 L super cab
Reply With Quote
  #7  
Old 04-23-2013, 03:09 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by dannmu64 View Post
Ok, I just got a used computer, pulled out the old one, visually looked fine. Had to deal with the anti-theft thing with the chip in the key. I have the plugs out and letting it dry out some. If this doesn't fix the problem do u think I could have a wiring issue with the computer?
it might be the injectors all so
What's your fuel pressure at?
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #8  
Old 04-23-2013, 03:09 PM
dannmu64 dannmu64 is offline
Learning to use the forums
 
Join Date: Apr 2013
Posts: 7
Default Re: 2.3 won't start, gas flooding or crank sensor?

50
__________________
2000 Ford Ranger XLT 4x4
3.0 L super cab
Reply With Quote
  #9  
Old 04-23-2013, 03:11 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by dannmu64 View Post
50
That's kinda high
More like really high lol
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #10  
Old 04-23-2013, 03:16 PM
dannmu64 dannmu64 is offline
Learning to use the forums
 
Join Date: Apr 2013
Posts: 7
Default Re: 2.3 won't start, gas flooding or crank sensor?

Where should it be at? Does that sound like a injectors themselves as a problem. I talked to a mechanic and he wasn't concerned about the fuel pressure being around 50. Might be closer to 47-49
__________________
2000 Ford Ranger XLT 4x4
3.0 L super cab
Reply With Quote
  #11  
Old 04-23-2013, 03:16 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by dannmu64 View Post
Where should it be at? Does that sound like a injectors themselves as a problem. I talked to a mechanic and he wasn't concerned about the fuel pressure being around 50. Might be closer to 47-49
Like 40 is good
idk I would try and find out why the pressure is so high
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
  #12  
Old 04-23-2013, 03:17 PM
dannmu64 dannmu64 is offline
Learning to use the forums
 
Join Date: Apr 2013
Posts: 7
Default Re: 2.3 won't start, gas flooding or crank sensor?

Thanks
__________________
2000 Ford Ranger XLT 4x4
3.0 L super cab
Reply With Quote
  #13  
Old 04-23-2013, 03:17 PM
96_4x4_XLT 96_4x4_XLT is offline
Ford Ranger Driver
 
Join Date: Mar 2013
Posts: 6,189
Default

Quote:
Originally Posted by 96_4x4_XLT View Post

Like 40 is good
idk I would try and find out why the pressure is so high
Might be flooding because the injectors can't handle the pressure and stay open but idk
__________________
95 Ranger XLT 4x2 2.3 I4 5 speed 206,000 *dead*
96 Ranger XLT 4x4 4.0 V6 5 speed 173,000 *alive*
D35 front, 8.8 rear, 3.73 gears, limited slip rear diff
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will crank, wont start problem. andrewhodge General Tech 9 12-03-2012 05:33 PM
Crank but no Start romanranger 4-Cylinder Tech 5 01-17-2011 01:12 PM
hard start, no start, ruff idle, poor gas mileage n more terryduanemiller General Tech 1 01-11-2011 09:42 AM
tricks to routing Crank sensor wiring ? KTMhauler 4-Cylinder Tech 1 08-26-2010 01:18 PM
86 2.9 help with crank sensor location valsound 2.9 Liter Tech 0 10-23-2009 01:31 PM