Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-17-2011, 02:08 PM
93xlt93 93xlt93 is offline
Like the Forums
Join Date: Jan 2011
Posts: 32
Default temp gauge?

ever since i got my truck a couple months ago the temp gauge in the cluster never moves even tho it spits out heat so today i decided to replace the temp sensor and still no movement what else could it be? and ideas?
Reply With Quote
Old 03-17-2011, 02:13 PM
BL4CKB4NN3R BL4CKB4NN3R is offline
Join Date: Mar 2011
Posts: 4
Send a message via Skype™ to BL4CKB4NN3R
Default Re: temp gauge?

Not really sure either, but I have the same problem. I've had multiple electronics problems in my truck and eventually my temp gauge just stopped. It stays all the way at zero position. I've changed the sensor and nothing.
Mazda B2500 SE 2.5L 4cyl 2RWD
Reply With Quote
Old 03-20-2011, 08:27 PM
fishon91 fishon91 is offline
Learning to use the forums
Join Date: Mar 2011
Posts: 6
Default Re: temp gauge?

my temp gauge wouldnt moive due to a bad sensor in the thermostat housing. the sensor is soldered to the therm housing and the solder had broke or something... also the therm housing had actually broken to where it holds the thermostat. but i just replaced the housing and my gauge worked.
is ur CEL on too? i would think it should be with the gauge not working
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
temp gauge adk General Ford Ranger Discussion 2 06-02-2011 04:13 PM
Temp gauge problem 98rangerxlt General Tech 1 02-16-2011 08:44 PM
temp gauge always on cold never goes above a 1/4 huffa12 3.0 Vulcan Tech 7 01-02-2011 06:56 PM
Temp Gauge RedFord 4-Cylinder Tech 3 11-01-2010 01:34 PM
Temp gauge not functioning twdavis416 Electrical Tech 2 11-23-2009 05:19 PM