Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #31  
Old 03-08-2011, 05:22 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: heater question

Quote:
Originally Posted by GhostZ View Post
thnks you two. my truck sat for 3 yrs before i bought it off the old man next door becaue he went senile and could not drive. and itt had the worst coolant in it ever. when i did the flush and cleaning a whole bunch or rust and some chunks came out with the water.
This thread lost me a while ago but that ^^^^^ should have been included in the first post.......napa sells a product b MAC for cleaning our your cooling system .it works great
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #32  
Old 03-08-2011, 05:27 AM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

i used that product lol and agree i should'v i just never thought about it till now.

please dont flame me guys CAUSE I probley just made ur decision making alot more different
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #33  
Old 03-08-2011, 05:36 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default

Don't worry, that's why we're here. Thats why I tend to ask a lot of annoying questions before answering sometimes too. If everyone knew everything, we would be here at all.

All the crap, rust, and chunks that come out... yea, that was the impeller from the water pump lol. So replace that for sure. Also, flush it again after you replace it and run it a bit since before you weren't circulating enough to really flush it out. I bet even more junk comes out. The sensor is cheap and can't hurt. Its probably a but rusty too.

[Posted with my Android mobile device using Tapatalk Pro]
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #34  
Old 03-08-2011, 11:37 AM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

okay guys here a littel update right now i brought the truck into the shop i work in. we hooked it up to the comp. and a manuel temp guage.

the sensor says its at 192* when the thermo opens

But in reality the t-stat opened up at 104* i think advanced sold me a faulty t-stat.

so i think i'm going back to the zone to get all my parts and my WP also which sensor do i get?
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #35  
Old 03-08-2011, 11:44 AM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: heater question

I'm confused about what you actually did. Can you try that again? Where did that 192 reading come from and where did the 104 reading come from?

None the less, the stat opening at 104 would certainly cause your symptoms. Remember way back in this thread I said it wouldn't be the first time a new t-stat was broke? I don't make this shit up I'd replace the water pump anyway, chances are its on its way out even if this problem was indeed the stat.

You have two sensors. One for the computer and one for the gauge. They are different. (computer one has more wires). I'd say the gauge one is working perfectly fine given your manual temperature reading jives with the gauge reading.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #36  
Old 03-08-2011, 11:52 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: heater question

Quote:
Originally Posted by GhostZ View Post
okay guys here a littel update right now i brought the truck into the shop i work in. we hooked it up to the comp. and a manuel temp guage.

the sensor says its at 192* when the thermo opens

But in reality the t-stat opened up at 104* i think advanced sold me a faulty t-stat.

so i think i'm going back to the zone to get all my parts and my WP also which sensor do i get?
I am a little confused about ^^^^^ but never the less......Advanced Sells Stant products. Is that the brand you got from them?.......I strongly recommend a Motorcraft T-Stat, however if you can get a stant that should be OK......you want one with a bleeder hole in it.....
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 03-08-2011 at 01:27 PM.
Reply With Quote
  #37  
Old 03-08-2011, 02:11 PM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

Quote:
Originally Posted by FireRanger View Post
I'm confused about what you actually did. Can you try that again? Where did that 192 reading come from and where did the 104 reading come from?

None the less, the stat opening at 104 would certainly cause your symptoms. Remember way back in this thread I said it wouldn't be the first time a new t-stat was broke? I don't make this shit up I'd replace the water pump anyway, chances are its on its way out even if this problem was indeed the stat.

You have two sensors. One for the computer and one for the gauge. They are different. (computer one has more wires). I'd say the gauge one is working perfectly fine given your manual temperature reading jives with the gauge reading.

okay sorry i was typing quick i was in english class lol

well nevermind about 192 after a second go at testing the truck ran for 1.5 hrs and the temp never got above 170* on our scanner (snap-on soulus) The manuel guage never got above 120*

i also stopped by the local ford dealership (personal friend is the shop manager) and talked to him. He said to replace the t-stat with a duralast one and the WP with a duralast one. (he knows i'm in school and dont have enough to pay the dealership cost) and that should hopefully fix the problem.

so fireranger u were completly correct on all this lol (dont worry i never doubted you)

So here after i get payed here tomorrow i'm gettin the WP and t-stat and i'm gonna spend a day replacing it all.
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #38  
Old 03-08-2011, 02:17 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: heater question

Excellent. If the pump is worn down to crap, post a picture of it too.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #39  
Old 03-08-2011, 02:41 PM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

i will be sure to that. thanks again
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #40  
Old 03-10-2011, 05:05 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: heater question

Quote:
Originally Posted by GhostZ View Post
i will be sure to that. thanks again
if you are totally broke you can buy a gmb waterpump from advance for $22......order it online with a discount and pick it up at the store
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #41  
Old 03-10-2011, 05:38 AM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

i got a duraalast pump from autozone fcor $30 and its brandnew and has a lifetime warrenty same as my thermostat i just bought from them to.


all is going in today at school so we'll see how it goes.

also about advanced auto. the luck i'v had with there stuff is the perscision slave cylinder i bought off them . other than that all my family and me have never had luck with them.
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #42  
Old 03-10-2011, 07:32 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: heater question

Quote:
Originally Posted by GhostZ View Post
i got a duraalast pump from autozone fcor $30 and its brandnew and has a lifetime warrenty same as my thermostat i just bought from them to.


all is going in today at school so we'll see how it goes.

also about advanced auto. the luck i'v had with there stuff is the perscision slave cylinder i bought off them . other than that all my family and me have never had luck with them.
it's Perfection not Precision and I believe they might be made by LUK........if your t stat does not have a bleeder on it make sure you drill one into it or else you will have a harder time getting the air out of the system
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #43  
Old 03-10-2011, 11:46 AM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

we use a vaccum sytem to take all the ait out and it also puts the coolant in. no bleeding required. its actually really cool
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
  #44  
Old 03-10-2011, 11:51 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: heater question

Quote:
Originally Posted by GhostZ View Post
we use a vaccum sytem to take all the ait out and it also puts the coolant in. no bleeding required. its actually really cool
Who is WE?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #45  
Old 03-10-2011, 01:50 PM
ColinS ColinS is offline
slingin' mud to the sky!
 
Join Date: Feb 2011
Posts: 1,252
Default Re: heater question

at our school. if u havent figured it out i go to school for mechanics also.


The final verdict was the water pump had a bearing go out (could feel it when turned by hand) also the t-stat was toast got a new one in now along with a WP.

now after all work is done. the truck runs at temp and the heater works now. when we flushed all the coolant. we took the old WP off and flushed it threw the hole it goes in also with the hole the t-stat sits in. then the rad. again. all in all it works a thousand times better.

thanks everyone again
__________________
Colin S. AGE: 18
1994 Ford Ranger XLT 4x4 reg. cab 4.0l 5spd, 2" SL , Summit Nomads 15x8, 30x9.5x15 Trail Digger M/T's, cab lights, spray in bed liner, custom tube bumper,

1994 Ford Ranger XLT 2.3l 5spd ext. cab. the loaner truck

1987 Camaro z28 383 to much to list

https://www.facebook.com/colinshriver

http://www.fordrangerforum.com/proje...anger-4x4.html
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
vacuum, heater controls, heater control valves n more help? terryduanemiller General Tech 17 10-31-2011 12:06 PM
block heater? or coolant heater 93xlt93 Other Engine Tech 4 02-25-2011 05:56 AM
Heater dangerous Electrical Tech 0 05-21-2010 12:27 PM
A/C / heater question 01 Ranger General Tech 1 02-15-2010 12:14 AM
Heater Treater Bighomedog11 General Ford Ranger Discussion 8 10-26-2009 08:19 PM