Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-27-2011, 06:04 PM
Westiedog Westiedog is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 12
Default Here we go...........

So today i was shoveling snow into the bed of my trucks and dumping it off multiple times. I noticed my A.B.S. light went on randomly. I do not notice any difference in my brakes though. Also my speedo started acting weird it bounces up and down sometimes or will ping to the right speed then drop down again. I don't know what is causing these problems or where to start to fix them. If anyone has any intel its greatley appreciated.

Also its a 2000 ranger 2.5l 2wd XLT with 109,000 on the dash.

Thanks.
Reply With Quote
  #2  
Old 01-27-2011, 06:10 PM
ben10 ben10 is offline
slut life
 
Join Date: Oct 2010
Posts: 3,014
Default Re: Here we go...........

i know my 99 4.0 4x4 ABS light will come on sometimes when im driving in the snow, if im sliding a lot... i didnt think too much of it, then it did it again when i when wheeling in the mud and sand, i kinda figured it was the ABS computer getting a work out from all the sliding.
__________________
99 extended cab, 4.0, auto, 33s, 4x4 lifted with some stuff done

98 2wd 2.5, 5 speed, dropped with some stuff done
Reply With Quote
  #3  
Old 01-27-2011, 06:13 PM
edgeman4.0 edgeman4.0 is offline
THE COMPLAINT DEPARTMENT
 
Join Date: Nov 2009
Posts: 3,962
Default Re: Here we go...........

your speedo is often linked to the abs sensor. also the snow will get in there and mess with it temporarily.. no worries, it'll go away when it dries up.
__________________
2001 Ford Ranger Supercab (4dr), Oxford White, 4.0 Sohc, 4x4, Manual trans (hurst equipped), 4:10's, 3" body lift.
Quote:
Originally Posted by Demon-FX4 View Post
The Edgeman sees his prey and strikes out from the darkness.
Quote:
Originally Posted by Rango88 View Post
Dont f+ck with Ch+ck
Reply With Quote
  #4  
Old 01-27-2011, 07:35 PM
Westiedog Westiedog is offline
Learning to use the forums
 
Join Date: Jan 2011
Posts: 12
Default Re: Here we go...........

Quote:
Originally Posted by edgeman4.0 View Post
your speedo is often linked to the abs sensor. also the snow will get in there and mess with it temporarily.. no worries, it'll go away when it dries up.
I hope your right! I also did more research after I posted this and i read that the abs is connected to the speed sensor in the axle. Thanks man.

----------

Quote:
Originally Posted by ben10 View Post
i know my 99 4.0 4x4 ABS light will come on sometimes when im driving in the snow, if im sliding a lot... i didnt think too much of it, then it did it again when i when wheeling in the mud and sand, i kinda figured it was the ABS computer getting a work out from all the sliding.
Thats what i thought at first. It has happend before in the snow so i thought nothing of it until i noticed the speedo acting up.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search