Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-30-2010, 05:30 PM
jostrickland jostrickland is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 19
Exclamation Please help

I had my ranger running good, next thing you know, the gauges flickered, so I tried shuting it off and took out the key and it kept running. A minute later it shut off. Now I have no power anywhere, not even the headlights will come on. I checked all the fuses and they were fine. Please Help!!
Reply With Quote
  #2  
Old 12-30-2010, 05:49 PM
DHEM DHEM is offline
Resident Red
 
Join Date: Dec 2009
Posts: 1,003
Default Re: Please help

sounds like the key switch is bad, buts thats only a guess
__________________
'05 2wd Ranger xl with the 3.0

MODS-Alpine head unit, throttle cable mod, Black Rock wheels, FX4 lvl II axle swap, pooleo's camo painted bezel and mustang dome, painted/aftermarket headlights/tails fold-a-cover and over 100 hp in stickers
Reply With Quote
  #3  
Old 12-30-2010, 07:54 PM
jostrickland jostrickland is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 19
Default Re: Please help

But the lights wont even come on...
Reply With Quote
  #4  
Old 12-30-2010, 08:33 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: Please help

Check that the battery terminal connections are tight. Then if the battery is dead. As far as it running with the key removed..probably the switch...or worse..a short somewhere in that circuit.
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #5  
Old 12-31-2010, 10:40 AM
03crewcabranger 03crewcabranger is offline
Real Trucks Rattle
 
Join Date: Nov 2009
Posts: 597
Default Re: Please help

I say replace the ignition switch, and have you tried using another battery?
__________________
05 Mitsubishi Lancer LS
03 Ford Ranger XL - SOLD!
01 Honda Civic LX
Reply With Quote
  #6  
Old 01-01-2011, 11:36 AM
jostrickland jostrickland is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 19
Default Re: Please help

Ok I found a 30 amp fuse between battery and starter, I changed that and now have power to the headlights. Still no power to anything else. Im so confused...
Reply With Quote
  #7  
Old 01-02-2011, 07:54 PM
jostrickland jostrickland is offline
Liking the Ford Ranger Forum
 
Join Date: Dec 2010
Posts: 19
Default Re: Please help

I got it running!!!!! I found another fuse by the fire wall under the hood by the stearing column!!
Reply With Quote
  #8  
Old 01-02-2011, 07:58 PM
DiabloBlanco DiabloBlanco is offline
Get Lifted.
 
Join Date: Nov 2010
Posts: 6,402
Default Re: Please help

lol congrats.
__________________
YZ the way to be!
The Brotherhood!

Mods to come: Camburg entry 6.0 system. FiberwerkX Fenders and bedsides. Tube bumper.
R.I.P. Jeff Ashton. 1992-2011
Reply With Quote
  #9  
Old 01-02-2011, 08:20 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Please help

Scared me.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search