Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-29-2010, 10:45 AM
Gum85 Gum85 is offline
Like the Forums
 
Join Date: Dec 2010
Posts: 31
Default Really rough idle and loss of power???

My 1997 Ranger has really rough idle and just recently I've been having an extreme loss of power. The loss of power is so bad that the slightest up hill bogs the motor down to the point of almost dying. When I slow down to make a turn or stop at a stop light the motor will usually die. The check engine light is on so I had the local Autozone run a OBD II scan and I was told it was the #1 cyl misfire code. I thought it might have something to do with MAF sensor so I tried testing it. The Chilton manual I got says to disconnect the MAF sensor and then start the truck and let idle while testing. So when I disconnected the MAF sensor my truck wouldn't start at all. Then I reconnected the MAF sensor and the truck starts just fine. Bottom line is I have no clue what could be causing this so any help would be greatly appreciated.
Reply With Quote
  #2  
Old 12-29-2010, 12:40 PM
DrIftKi7Vg DrIftKi7Vg is offline
Sunny Soonkyu <3
 
Join Date: Aug 2009
Posts: 4,401
Send a message via AIM to DrIftKi7Vg Send a message via MSN to DrIftKi7Vg
Default Re: Really rough idle and loss of power???

Well, if you got a code from Autozone saying that you are having a #1 Cyl Misfire, then, you need to change your spark plugs (all of them) and check your plug wires to make sure they are okay. I had the same code before and I was getting bad sounds from my engine bay and I wasn't getting a lot of power either. Changed the plugs and wires and problem solved. Good luck!
__________________
Sunny
2002 Ford Ranger Edge Flex Fuel 2wd
LED Crazy!
Complete Pioneer Audio setup
5000k HID Projector retrofit and 3000k Fogs
Super Turbo Dynomax Exhaust
Mustang Dome Light Mod - Fog Light Mod
Achilles Desert Hawk 255/45/20 with 20'' rims

Much more!
Reply With Quote
  #3  
Old 12-29-2010, 01:17 PM
Gum85 Gum85 is offline
Like the Forums
 
Join Date: Dec 2010
Posts: 31
Default Re: Really rough idle and loss of power???

I changed all plugs and plug wires about 5 months ago so that shouldn't be the problem.
Reply With Quote
  #4  
Old 02-06-2012, 09:22 PM
donovan donovan is offline
Learning to use the forums
 
Join Date: Feb 2011
Posts: 4
Default Re: Really rough idle and loss of power???

sorry if this is old but just throwing my 2 cents in.It could be your Idle Air Control Valve(IAC),ive had issues with mine(97 ranger)and my sisters(97explorer) trucks.just take it off clean it with carb cleaner and it might make a dramatic difference and heck to clean it just costs some carb spray.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
loss of power RangerLuc 4.0 SOHC / 4.0 OHV Tech 9 05-31-2010 07:45 AM
power loss coop10 3.0 Vulcan Tech 2 03-06-2010 03:30 PM
2.5L power loss pepper809 4-Cylinder Tech 2 11-30-2009 09:12 PM
rough idle and loss of power eibbor697 3.0 Vulcan Tech 0 10-21-2009 12:27 PM
Loss of power califjeff 4-Cylinder Tech 5 08-28-2009 08:51 PM