Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 12-24-2010, 06:39 PM
nocauserebelx nocauserebelx is offline
Prerunner Jibber
 
Join Date: Oct 2010
Posts: 190
Default 2.3 turns over but wont fire

i just swapped an explorer axle into my ranger and now it is raked higher in the front and the gas tank is at an angle, when i turn my ignition on i dont hear the fuel pump prime, is this because the angle, fuel filter, fuel line....?
Reply With Quote
  #2  
Old 12-25-2010, 04:46 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: 2.3 turns over but wont fire

Quote:
Originally Posted by nocauserebelx View Post
i just swapped an explorer axle into my ranger and now it is raked higher in the front and the gas tank is at an angle, when i turn my ignition on i dont hear the fuel pump prime, is this because the angle, fuel filter, fuel line....?
check the inertia switch, fuses, etc.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 12-25-2010, 01:33 PM
nocauserebelx nocauserebelx is offline
Prerunner Jibber
 
Join Date: Oct 2010
Posts: 190
Default Re: 2.3 turns over but wont fire

i checked the fuses they were good but i cant get to my truck right now to check the inertia switch, what should it look like, is the button supposed to be down or up should i push it?

Last edited by nocauserebelx; 12-25-2010 at 01:52 PM.
Reply With Quote
  #4  
Old 12-28-2010, 12:26 PM
nocauserebelx nocauserebelx is offline
Prerunner Jibber
 
Join Date: Oct 2010
Posts: 190
Default Re: 2.3 turns over but wont fire

wierd, i left the truck sit for two days then came back and tried again. when i cranked it for a few seconds it made a loud thud and started up smoking more than i have ever seen. it drives now and sometimes still gets hung up on starting, it did it once more but this time i stabbed the gas a couple times and it fired up, is this a clogged fuel filter, bad pump?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.9 wont start, no fire foxracer01 2.9 Liter Tech 10 12-24-2010 09:17 PM
engine turns but wont start vzmaradona 4-Cylinder Tech 4 12-04-2010 11:02 PM
A/C turns off on Hway adamshoots 4-Cylinder Tech 1 06-23-2010 09:45 PM
E brake light turns off and on jdcarrion621@hotmail.com Electrical Tech 4 03-22-2010 09:08 AM
3.0 no fuel no spark turns over TiptonZ 3.0 Vulcan Tech 1 10-06-2009 10:40 AM