Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-27-2009, 01:09 PM
califjeff califjeff is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 3
Default Loss of power

New to the site,
I have a 96 ranger 5 speed. The problem i'm having is loss of power, stumbles, and at night my header where it hooks up to my exhaust glow cherry red and the check engine light hasn't come. Any help would be great
Jeff
Reply With Quote
  #2  
Old 08-27-2009, 01:28 PM
Johnbaum13 Johnbaum13 is offline
<-----Buzz Killington
 
Join Date: Jul 2009
Posts: 1,232
Send a message via Yahoo to Johnbaum13
Default

which engine?
__________________
I got my Jesus on the dashboard, but the Devil's under my hood!
Reply With Quote
  #3  
Old 08-27-2009, 01:40 PM
califjeff califjeff is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 3
Default

4 cyl
Reply With Quote
  #4  
Old 08-28-2009, 12:22 PM
mr.ranger mr.ranger is offline
Ford Ranger Driver
 
Join Date: Jul 2009
Posts: 652
Default

cherry red? that must be insanely hot then
__________________
GOING TO BUY a 2009 ford ranger sport 4X4 ..currently saving up enough money
debating on the colour (red, blue or black?)
updating once i buy my baby
Reply With Quote
  #5  
Old 08-28-2009, 12:24 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

May sound dumb but have you checked to see if your exhaust clogged.
__________________
2005 Edge

Reply With Quote
  #6  
Old 08-28-2009, 08:51 PM
califjeff califjeff is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 3
Default

Thats what i was thinking also, maybe the cat. i heard of people knocking out the center and reinstalling them. but thats means a new one before smod time
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
98' 3.0L... No acceleration, power, or pep HarveyT1184 3.0 Vulcan Tech 30 12-30-2011 05:42 PM
Power for an Add-on Radio cheiss8078 Audio / Video 0 08-19-2009 05:16 PM
power upgrades 00ford 3.0 Vulcan Tech 0 07-15-2009 01:42 PM
3.0 needs a power boost. sho_or_go 3.0 Vulcan Tech 6 07-15-2009 08:19 AM
Power Steering '97 4.0 V6 pmadill General Tech 2 05-20-2009 01:54 PM