Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-26-2009, 07:31 PM
baldy3220 baldy3220 is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 2
Default not revving high

my friends 96 Ranger 2.3 has a bad timing belt. He got it replaced but now when it gets to 3000 rpm it just dies down, and it is timed right.
Reply With Quote
  #2  
Old 08-26-2009, 07:43 PM
Johnbaum13 Johnbaum13 is offline
<-----Buzz Killington
 
Join Date: Jul 2009
Posts: 1,232
Send a message via Yahoo to Johnbaum13
Default

how 'bout the cam sensor? Sounds like the ignition timing may not be picking up right.
__________________
I got my Jesus on the dashboard, but the Devil's under my hood!
Reply With Quote
  #3  
Old 08-26-2009, 08:01 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Ya sounds like a cam sensor isn't right

Did a shop do it or did he do it?
__________________
2005 Edge

Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idol on '97-IAC troubleshooting denverdamon 3.0 Vulcan Tech 2 08-19-2009 05:46 AM
high rpm between gears i0wafarmer13 4-Cylinder Tech 1 06-12-2009 08:13 AM
high rpm between gears i0wafarmer13 4-Cylinder Tech 0 05-31-2009 02:01 PM
high rpm between gears i0wafarmer13 Drivetrain Tech 6 04-29-2009 05:27 PM
My ford Ranger 05 keeps making this high pitch noise when in high gear? rickymercer17 General Ford Ranger Discussion 1 12-08-2008 07:40 PM