Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 11-23-2010, 02:32 PM
brew76 brew76 is offline
Learning to use the forums
Join Date: Sep 2010
Posts: 1
Question 94 2.3L No power!! HELP PLEASE!!

Hi y'all I have a 94 with a 2.3L. I have replaced fuel pump and filter, both coil packs, plugs and wires, and ICM. I have cleaned the MAF, throttle body, and AICV.
I'm not getting any spark at the pack or plug on the intake side #3. It idles fine besides the miss, 1st is about 90% on power, 2nd is about 80, 3rd is 60ish, 4th is about 25 and doesn't gain any speed. I understand this has to do with only running on 3 cylinders. What am I missing that would keep me from having spark????
I'm into this thing to much to just trash it, plus I'm kinda fond of the old girl. She is also my DD. Any help would be appreciated.

Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get more power out of my 2.5L?? RangeRZ08 4-Cylinder Tech 51 01-24-2011 10:24 AM
Got some Power! Ranger01 3.0 Vulcan Tech 10 10-05-2010 01:10 PM
94 2.3 has power, clicks, then no power no start rumpranger 4-Cylinder Tech 2 09-02-2010 09:27 AM
Replace passenger side power rear view mirror on 2005 Ranger with power windows Theodore Viera Interior Tech 2 06-21-2010 09:39 PM
need help for more power mazdadan 4.0 SOHC / 4.0 OHV Tech 0 01-20-2010 06:27 PM