Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-20-2009, 05:39 PM
crc124 crc124 is offline
Learning to use the forums
 
Join Date: Aug 2009
Posts: 1
Exclamation Need help!!

I have 2000 ford ranger 2.5l

Everytime I rolling my truck in neutral and rpm goes excessive and then when truck is full stop rpm goes back to normal. I have replaced TPS and Bypass Valve Sensor and both are not help
Does anyone have same problem as mine before? and got it fixed? please lemme know
Reply With Quote
  #2  
Old 09-19-2009, 11:18 PM
shawn shawn is offline
94 2.3 5 sp danger ranger
 
Join Date: Sep 2009
Posts: 102
Default

sounds to me like a vacuum leak or possibly a bad mass air flow sensor maybe even a throttle position sensor either one is cheap and easy to fix
Reply With Quote
  #3  
Old 09-20-2009, 06:31 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

try cleaning your MAF first couple bucks for the cleaner at a auto store
__________________
2005 Edge

Reply With Quote
  #4  
Old 09-21-2009, 11:34 AM
blueovelboy blueovelboy is offline
GO SHARKS
 
Join Date: Aug 2009
Posts: 1,523
Default

PS don't touch that little needle or stick in middle with you fingers or spray it to close with the cleaner or you ll be screwed
__________________
Jay's
09 XL reg cab
L4 2.3 , 40 series flowmaster , tinted windows 5% back 35% sides ,muffler removed from air box mod ,and ac on off switch mod , blinker mod, avs window vent shades
coming soon! k&n drop in/fiberglass bed cover/bed sprayed liner
Reply With Quote
  #5  
Old 10-11-2009, 10:45 PM
lowepat94danger lowepat94danger is offline
Learning to use the forums
 
Join Date: Oct 2009
Posts: 5
Default

you dont even need your MAF, just run it with out it
Reply With Quote
  #6  
Old 10-12-2009, 07:00 AM
blueovelboy blueovelboy is offline
GO SHARKS
 
Join Date: Aug 2009
Posts: 1,523
Default

Quote:
Originally Posted by lowepat94danger View Post
you dont even need your MAF, just run it with out it
ok then dont run it and watch your truck not know how much gas to give the motor. see if it runs lean and you fry a piston, or run rich and you foul your plugs, clog your cat. your right you dont need your MAF sensor. ford just put them there for looks and so thay could charge you more for the truck. man i wish people would think be for thay just jump out with there so called knowledge and look stupid.
__________________
Jay's
09 XL reg cab
L4 2.3 , 40 series flowmaster , tinted windows 5% back 35% sides ,muffler removed from air box mod ,and ac on off switch mod , blinker mod, avs window vent shades
coming soon! k&n drop in/fiberglass bed cover/bed sprayed liner
Reply With Quote
  #7  
Old 10-12-2009, 07:06 AM
lowepat94danger lowepat94danger is offline
Learning to use the forums
 
Join Date: Oct 2009
Posts: 5
Default

i am hoping you are talking about the guy who said to clean the MAF and not me cause u really dont need that maf.
Reply With Quote
  #8  
Old 10-12-2009, 07:32 AM
DieHard4rd DieHard4rd is offline
The Old Guy
 
Join Date: Jul 2009
Posts: 4,824
Default

This is going to be good!
Reply With Quote
  #9  
Old 10-12-2009, 08:04 AM
blueovelboy blueovelboy is offline
GO SHARKS
 
Join Date: Aug 2009
Posts: 1,523
Default

? ? ?
WTF
ok
__________________
Jay's
09 XL reg cab
L4 2.3 , 40 series flowmaster , tinted windows 5% back 35% sides ,muffler removed from air box mod ,and ac on off switch mod , blinker mod, avs window vent shades
coming soon! k&n drop in/fiberglass bed cover/bed sprayed liner
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search