Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 11-01-2010, 05:07 AM
ogie56 ogie56 is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 3
Default heat only after 10 min. and driving down the road

Hi, first post i have a 1996 ranger 4 cyl. manual tran. i can only get heat after idling about ten minutes and going down the road about five or so miles, after that it puts out all kinds of heat. put in a new t-stat yesterday no help. idea's ?
Reply With Quote
  #2  
Old 11-01-2010, 01:42 PM
Mirage Mirage is offline
Ford Ranger Owner
 
Join Date: Aug 2010
Posts: 50
Default Re: heat only after 10 min. and driving down the road

Yep, here's one.. If you follow the heater hoses back from the where they enter the firewall, towards the radiator, you'll find a little valve inline with one of the hoses. It is vacuum controlled and it's possible the diaphram is leaking or the vacuum hose is rotting away/collapsed. Had this happen to mine with the same symptoms. Replaced the diaphram and worked as it should for about a week, then the heater core started leaking... but that's another story.... Never another problem with the diaphram though.
__________________
1996 Mazda B2300 SE
5 Speed Stick
Extended Cab
(Well it's almost a Ranger!)
Reply With Quote
  #3  
Old 11-01-2010, 07:26 PM
ogie56 ogie56 is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 3
Default Re: heat only after 10 min. and driving down the road

no i don't have that no a/c just heater,plain jane 4 cyl. with manual tranny , i read some other posts, think it might be the water pump not working good. i have heat after you drive then the gauge also is up to line above the C mark and both heater hoses are hot ,but no heat at idle and gauge goes back to cold thanks for the Idea
Reply With Quote
  #4  
Old 11-01-2010, 07:35 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: heat only after 10 min. and driving down the road

Hmm. Well as silly as this sounds, I'd go back to the t-stat. There are lots of things that can cause an engine to overheat. But there is really only one thing that can cause it to not heat up and that is a thermostat stuck open. I seem to recall that it used to be possible to put them in upside down or backwards or something but I'm not sure if its even possible with ours.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
  #5  
Old 11-01-2010, 08:02 PM
ogie56 ogie56 is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 3
Default Re: heat only after 10 min. and driving down the road

just put in a new t-stat and it only sets in one way ,thanks
Reply With Quote
  #6  
Old 11-01-2010, 08:25 PM
FireRanger FireRanger is offline
Blinded by the light
 
Join Date: Sep 2009
Posts: 7,674
Send a message via AIM to FireRanger
Default Re: heat only after 10 min. and driving down the road

I know. But my point is that there is nothing else that can cause this condition. Any other failure or worn out part would cause too much heat, not less heat. So even though you just put a new one in, I would still go back and do it again since there's nothing else.
__________________
(Formerly)
FireRanger
2003 Edge 4.0 4wd

How to: Aux light wiring, relays, & fuses
Info: 300+ intake threads here on FRF
Info: HID Projectors
How To: NO HEAT Troubleshooting Guide
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
No heat jveigl General Tech 68 01-02-2012 07:36 PM
3" lift - last min check desjardo Lifted Suspension 17 02-19-2011 04:12 PM
I need everyones help with a school project (will only take a few min!) Alon General Ford Ranger Discussion 53 11-03-2010 08:08 AM
2000 Ranger dies then starts within 1 min alatina General Tech 1 09-16-2010 06:26 PM
A/C cold for a few min then warm. WTH?! Help! Jwad00 General Tech 9 06-24-2010 01:02 PM