Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-16-2010, 12:07 PM
handsupthumbsdown handsupthumbsdown is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 1
Default Any ideas?

Hi folks, first time poster. My '98 Ranger (112k, 5 speed, 2.5) is making little clanging noise when first accelerating. It's coming from under the hood for sure. It's difficult to describe but it only happens at very low RPMs (like when just getting moving in 1st and then early on in 2nd).

I'm thinking that the timing belt might be to blame. Any other ideas?
Reply With Quote
  #2  
Old 09-20-2010, 12:43 AM
tileguy tileguy is offline
tileguy
 
Join Date: Sep 2010
Posts: 11
Default Re: Any ideas?

check your pullys look for missing or broken bolts,/" altenator"?Knuckle up
__________________

Last edited by tileguy; 09-20-2010 at 12:46 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I need ideas! WVRanger Audio / Video 7 05-30-2011 11:36 AM
Sub ideas: All are welcome reconjb Audio / Video 28 10-18-2010 08:12 PM
need ideas winslow33 General Ford Ranger Discussion 6 09-07-2010 05:22 AM
Any ideas? StxRanger2006 Exterior Tech 2 07-22-2010 02:05 PM
Sub ideas timorpheus Audio / Video 4 04-15-2010 07:59 PM