Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-01-2010, 10:56 AM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default keep killing fuel pumps

Ok I'm on my fifth pump in 1 year, my last pump made it to my shop only 50 miles. New filter new regulator new sock filter lines look good, no kinks, so I'm lost. The pump will run just no pressure. I tried to hard wire the pump and have the same probles, pump runs no pressure. And when I say no pressure I'm talking at the fuel hat. Its a 96 with a 2.3l I have tried all I know to do so please help. Thanks justin
Reply With Quote
  #2  
Old 09-01-2010, 11:06 AM
Willy Mo Willy Mo is offline
Ford Pickup
 
Join Date: Aug 2010
Posts: 100
Default Re: keep killing fuel pumps

clogged inside the fuel hat? clogged inside the tank? rusty tank?
__________________
97' 2.3 5spd
Riding on aiR
Reply With Quote
  #3  
Old 09-01-2010, 12:39 PM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default Re: keep killing fuel pumps

Pulled the tank last week and cleaned and I can blow freely through the hat. I have tried dang near everything lol.
__________________
2000 Lightning not stock ; )
1996 Ranger 2.3l DD
Reply With Quote
  #4  
Old 09-01-2010, 01:31 PM
Willy Mo Willy Mo is offline
Ford Pickup
 
Join Date: Aug 2010
Posts: 100
Default Re: keep killing fuel pumps

check voltage to the pump? compare to service manual.
__________________
97' 2.3 5spd
Riding on aiR
Reply With Quote
  #5  
Old 09-01-2010, 02:00 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: keep killing fuel pumps

Quote:
Originally Posted by justin00svt View Post
Ok I'm on my fifth pump in 1 year, my last pump made it to my shop only 50 miles. New filter new regulator new sock filter lines look good, no kinks, so I'm lost. The pump will run just no pressure. I tried to hard wire the pump and have the same probles, pump runs no pressure. And when I say no pressure I'm talking at the fuel hat. Its a 96 with a 2.3l I have tried all I know to do so please help. Thanks justin
I dont know what the fuel hat is, however your regulator should be on the fuel rail and you said you replaced it right? did you change the whole setup in the tank or just put a new pump on the setup?.you said the pump runs so it cant be the inertia switch? strange
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #6  
Old 09-01-2010, 02:01 PM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default Re: keep killing fuel pumps

Voltage is 13.5 I don't know what spec is but that should be good IMO.
__________________
2000 Lightning not stock ; )
1996 Ranger 2.3l DD
Reply With Quote
  #7  
Old 09-01-2010, 02:03 PM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default Re: keep killing fuel pumps

Yeah I only changed the pump itself. Its almost like they have a built-in popoff
__________________
2000 Lightning not stock ; )
1996 Ranger 2.3l DD
Reply With Quote
  #8  
Old 09-01-2010, 02:06 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: keep killing fuel pumps

Quote:
Originally Posted by justin00svt View Post
Ok I'm on my fifth pump in 1 year, my last pump made it to my shop only 50 miles. New filter new regulator new sock filter lines look good, no kinks, so I'm lost. The pump will run just no pressure. I tried to hard wire the pump and have the same probles, pump runs no pressure. And when I say no pressure I'm talking at the fuel hat. Its a 96 with a 2.3l I have tried all I know to do so please help. Thanks justin
I am guessing the "fuelhat"is the whole setup part that fits into the tank. is the check valve in the fuel hat or in the regulator. I know you said you could blow thought it.......just wondering if the check valve could be stuck closed....
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #9  
Old 09-01-2010, 02:09 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: keep killing fuel pumps

Quote:
Originally Posted by justin00svt View Post
Yeah I only changed the pump itself. Its almost like they have a built-in popoff
I dont know what a popoff is but I wonder if the check valve is in that setup(fuel hat) and is clogged somehow.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #10  
Old 09-01-2010, 02:15 PM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default Re: keep killing fuel pumps

I can't see it getting clogged in 50 miles with a new sock on it but I have seen crazier things.
__________________
2000 Lightning not stock ; )
1996 Ranger 2.3l DD
Reply With Quote
  #11  
Old 09-01-2010, 02:21 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: keep killing fuel pumps

Quote:
Originally Posted by justin00svt View Post
I can't see it getting clogged in 50 miles with a new sock on it but I have seen crazier things.
my guess is something in the setup(fuel hat) is trashed. maybe you can bring the pump back and just buy the pump with the setup?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #12  
Old 09-01-2010, 02:52 PM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default Re: keep killing fuel pumps

I have sprayed brake cleaner through the hard lines on the hat they seem to be fine.
__________________
2000 Lightning not stock ; )
1996 Ranger 2.3l DD
Reply With Quote
  #13  
Old 09-01-2010, 03:01 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: keep killing fuel pumps

Well this aint Brain surgery. You have a clogged line or a stuck relay that is burning out your pump

Also you said you brought power directly to the pump
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #14  
Old 09-01-2010, 03:06 PM
justin00svt justin00svt is offline
Learning to use the forums
 
Join Date: Sep 2010
Posts: 8
Default Re: keep killing fuel pumps

I know it isn't brain surgery lol and thanks for that but anywho I must have a clogged line but how when I have blown through them all? It just doesn't make any since to me so idk I'm just getting tired of look for a problem but I am really loving the quick feedback thank you.
__________________
2000 Lightning not stock ; )
1996 Ranger 2.3l DD
Reply With Quote
  #15  
Old 09-01-2010, 04:49 PM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: keep killing fuel pumps

Quote:
Originally Posted by justin00svt View Post
I know it isn't brain surgery lol and thanks for that but anywho I must have a clogged line but how when I have blown through them all? It just doesn't make any since to me so idk I'm just getting tired of look for a problem but I am really loving the quick feedback thank you.
I guess i don't know what else to say. you have burnt out 5 pumps and you say all the lines are clear and I guess you said that the relay is working and not keeping the pump on all the time. You also said that you hooked the pump up directly to the battery and it still will not pump it makes noise but will not pump......I am out of ideas......
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Sensor...Fuel Pump...???? vang0017 4.0 SOHC / 4.0 OHV Tech 23 10-26-2015 11:58 AM
98 Frontend Squeak killing me 98 X Cab Suspension Tech 23 02-27-2012 12:47 PM
how many fuel pumps on 88 ranger 4x4 dickl67 4-Cylinder Tech 8 04-19-2010 01:56 PM
This is killing me Mkrok 4-Cylinder Tech 0 01-01-2010 06:18 PM
Ford ranger 2.3L 4 cylinder fuel pumps wont turn on ? Edyram18 General Ford Ranger Discussion 3 12-25-2008 08:19 PM