Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-22-2010, 12:49 PM
mikef mikef is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 4
Default Help!!! 96 Ranger 2.3 Rattling in idle, stalls

Hello Guys,

I have a problem with my little truck:
-First when you attempt to start it it stalls immediately
-After few attempt and constantly pumping gas it will start and idles very rough (after a warm up), Backfires and exhaust gets cherry red
- have p1504 and p0122 codes

what I've done so far:
- New fuel filter, pressure is good
- Checked all Fuses
- Replaced timing belt 3 times
- checked the vacuum the best I could
- checked wiring from TPS and IAC to PCM
- Checked output on TPS (left wire 5V, middle -1.0V -closed, 4.5x - full open, right is nothing 0)

simmilar to this

I've spent countless ours online and in the garage trying to figure it out. Would appreciate any input.
Reply With Quote
  #2  
Old 08-22-2010, 05:39 PM
scheider1980 scheider1980 is offline
Ford Ranger Owner
 
Join Date: Nov 2009
Posts: 63
Default Re: Help!!! 96 Ranger 2.3 Rattling in idle, stalls

cat is bad
Reply With Quote
  #3  
Old 08-23-2010, 04:44 AM
mikef mikef is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 4
Default Re: Help!!! 96 Ranger 2.3 Rattling in idle, stalls

Cat is bypassed. But still will try without exhaust.
Reply With Quote
  #4  
Old 08-24-2010, 04:30 PM
mikef mikef is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 4
Default Re: Help!!! 96 Ranger 2.3 Rattling in idle, stalls

Here is update:
Changed 1st Coil pack
replaced IACV
removed Exhaust
Truck starts fine, but shuts off after 1-2 sec
Any Ideas? I am stuck and cannot think anything but vacuum or PCM
Reply With Quote
  #5  
Old 08-25-2010, 10:35 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: Help!!! 96 Ranger 2.3 Rattling in idle, stalls

Quote:
Originally Posted by mikef View Post
Here is update:
Changed 1st Coil pack
replaced IACV
removed Exhaust
Truck starts fine, but shuts off after 1-2 sec
Any Ideas? I am stuck and cannot think anything but vacuum or PCM
we need more info. does it start up and die after 2 seconds everytime? Does it ever run for a while. have you gotten any more codes? what was the fuel pressure? koeo, koer( when it was runing) how many cycles to get to proper pressure. how much did the pressure drop in 5 minutes after you shut the truck off.

a few more thoughts. I think you have a icm. did you try disconnecting sensors one at a time. ie. the maf, the ect sensor. did you check that the air intake was not clogged up. did you try spraying starter fluid into the throttle body to see if it ran? how about spark?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #6  
Old 09-04-2010, 06:08 PM
mikef mikef is offline
Learning to use the forums
 
Join Date: Aug 2010
Posts: 4
Default Re: Help!!! 96 Ranger 2.3 Rattling in idle, stalls

Ok I guess I need to do the followup and share the knowledge!

First - Thank you for your help and time that you invested in my problem. I really do appreciate it.

And now solution to my problem: Since truck will run just fine on break cleaner and exhaust gettin red hot after 1-1.5 min we decided that it was timing. After another attempt to change timing belt my buddy pointed at the crankshaft pulley. The notch was 3 times bigger than alignment pin, so the knock sensor did not know which position the engine was in.

I will skip my journey to the junk yard, just wanna let you know that advance and autozone dont have those pulleys for 4cyl, but they have for V6.


PS anybody needs a computer? F67F-12A650-VA writing ZZQ0
)))))))
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
engine stalls when put in park AllBlackRanger4x4 General Tech 3 01-06-2010 07:07 PM
Catalytic Converter / O2 Sensor bad - exhaust rattling at idle, power cut in/out??? bwheeler General Tech 4 11-15-2009 12:55 AM
My 1990 Ranger 2.9, stalls at stops. paul_coplin General Tech 0 08-29-2009 08:12 PM
Engine Stalls Jared General Tech 2 07-02-2009 07:45 PM
4.0l v6 stalls when AC compressor cycles off DQuinn 4.0 SOHC / 4.0 OHV Tech 0 06-04-2009 10:33 AM