Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-29-2010, 06:12 PM
bolivartech bolivartech is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 30
Exclamation Speedometer Dead!

Well I still love my '00 Ranger, but it is making harder everyday. I just got the power steering replaced and the high pressure hose and now the Speedometer is dead. I am getting ready to replace the instrument cluster so should I wait till I've done the swap before I try to figure this out, or is it best to do it before.

If before, any suggestion on what to check? I know there is no speedo cable, so is there a wire loose somewhere? The engine compartment had a lot of fluid in it from the power steering going out (high pressure hose... failed...). Thanks for the help, again!
Reply With Quote
  #2  
Old 07-30-2010, 06:27 AM
bolivartech bolivartech is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 30
Default Re: Speedometer Dead!

Well I didn't figure out what was wrong, but I'm about to speculate since it's working now ;-) I recently had to replace my power steering and fluid was everywhere (reminded me of when the radiator in my mustang exploded, only less damage). After getting it fixed I gave it a good clean in the engine bay, and then took it to the car wash because I had plain made a mess. I'm thinking that was it, just too wet, because this morning it works fine, and drives better than it did last night.

We took a long drive in it last night because it had been sitting for quite a few days, engine never got up to normal temp and had trouble idling but all is well today.

Yea for things that work themselves out!
Reply With Quote
  #3  
Old 07-30-2010, 06:30 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Speedometer Dead!

I was gonna suggest the gears for the speedometer were messed up

glad to see it working again
__________________
2005 Edge

Reply With Quote
  #4  
Old 07-30-2010, 07:14 AM
ranger5572 ranger5572 is offline
2004 XLT with a few mods
 
Join Date: Jun 2010
Posts: 312
Default Re: Speedometer Dead!

My tach started showing RPMs over 4500 2 nights ago at normal speed. I turned the engine off at a light and the tach dropped down to 2000 or so instead of to the '0' where it should have been. Turned it back on and same thing...4500 while driving 45MPH in 5th. Crazy thing though, the next (yesterday) I hadn't even looked at it til 5 miles down the road. It was working fine. right at 2300ish RPM at 45MPH just like it never happened. It fixed itself.
__________________
2004 XLT 4.0 4x4, 3" PA body lift, 32" BFG M/Ts, Dick Cepek DC-2 wheels, Euro tailights, self-painted headlight mod, NAV/DVD/XM/iPod stereo (Pioneer AVIC-D3), Line-X, Westin step bars, AVS bug shield and window vents
Reply With Quote
  #5  
Old 08-06-2010, 10:30 AM
bolivartech bolivartech is offline
Like the Forums
 
Join Date: Jun 2010
Posts: 30
Default Re: Speedometer Dead!

Well my luck never does last. As soon as I swapped the gauges it stopped working again. Now I don't know if it's the new gauges or something more to do with the Speedometer itself. Everything else on the the new cluster works fine, including the Tachometer which that and the fact that all the back lights were burnt out were the reason for the swap. So at the very least I can drive it using the tach, but I need to figure out what's up with the speedo asap.
Reply With Quote
  #6  
Old 08-06-2010, 10:43 AM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: Speedometer Dead!

Maybe an broken wire making an intermitant connection? Try checking your connection to the transmission underneath for a loose wire in the connector or a loose connector.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #7  
Old 08-06-2010, 02:24 PM
drppdyllwrngr drppdyllwrngr is offline
Ford Ranger Driver
 
Join Date: Feb 2010
Posts: 3,122
Default Re: Speedometer Dead!

98+ gets the signal from the abs ring on the rear end. that sensor goes out. may be a place to start. is your abs light on?
__________________
Krylon Fusion is for Amateurs.
Reply With Quote
Reply

Tags
speedometer

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is Rock dead? RangerChad Music/Movies/Computers/etc. 22 07-23-2011 04:42 PM
Dead Battery svtmusic 4-Cylinder Tech 1 07-29-2010 05:42 PM
dead headlights 88 2 wd striper2301 General Ford Ranger Discussion 2 12-09-2009 12:32 PM
My Duck is dead greyghost Laugh Factory 1 10-30-2009 05:18 AM
FX4 dead? surfer03133 General Ford Ranger Discussion 14 09-27-2009 08:00 AM