Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 07-22-2010, 01:58 PM
blackdout89range blackdout89range is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 13
Default Engine mount (broken, need help!!)

So, last night i had loaded up some trash in the bed of my truck, and after leaving my buddys driveway, (nothing too harsh, just coasted out of the driveway), it became extremely difficult to turn. so i drove a little, and we dumped the trash, and i was hoping the truck was just squatting so hard from the weight that it was difficult to turn. ..... Wrong

So, i figured out that if i was in a lower gear at a higher RPM, i could turn easily.
power steering? nope.
today i find that the ds of my engine is sitting about an inch or two lower, my dizzy (the right side one) is resting on my rag joint of my steering shaft, and the belt that goes to the alt/ psteering is touching my ps lines.


Cliff notes;

Truck won't turn unless engine is under heavy throttle.
drivers side of engine is squatting 1-2 inches lower.
distributor is resting on steering shaft >.<
ps pump and belt are resting on lines.

i think i broke a motor mount?
__________________
bonestock 89 ranger xlt 2.3l 5spd 2wd. Ridin high (stock), handles like crap, slower than hell, and i love it.
Reply With Quote
  #2  
Old 07-22-2010, 02:27 PM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default Re: Engine mount (broken, need help!!)

yep, sounds like a bad mount to me.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #3  
Old 07-22-2010, 02:54 PM
blackdout89range blackdout89range is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 13
Default Re: Engine mount (broken, need help!!)

So, realistically, how many hours you think it's gonna take, and how much shit am i gonna have to take off/ move to get to it? I'm super new to rangers, and i remember swapping mounts in an s10 were no picnic, and i cant even see it on the ranger.
__________________
bonestock 89 ranger xlt 2.3l 5spd 2wd. Ridin high (stock), handles like crap, slower than hell, and i love it.
Reply With Quote
  #4  
Old 07-22-2010, 08:10 PM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: Engine mount (broken, need help!!)

It depends. If your set up is like the 2.5L, it shouldn't be too bad once you get the engine jacked up some. Just make sure you have some 1/2" tools with six point sockets. You might have to do some heavy cranking to get the bolts out.

Just use a floor jack with a board on the pad to keep from messing up you oil pan.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #5  
Old 07-22-2010, 09:17 PM
blackdout89range blackdout89range is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 13
Default Re: Engine mount (broken, need help!!)

alright, i've got plenty of tools, breaker bars, extensions etc. also, a cherry picker so i mean i'm hopefully set. haha. thanks all for the help, i'll let you know how it goes.
__________________
bonestock 89 ranger xlt 2.3l 5spd 2wd. Ridin high (stock), handles like crap, slower than hell, and i love it.
Reply With Quote
  #6  
Old 07-23-2010, 01:50 PM
blackdout89range blackdout89range is offline
Learning to use the forums
 
Join Date: Jul 2010
Posts: 13
Default Re: Engine mount (broken, need help!!)

thanks for the wisdom, FRF! it took my brother and i about an hour to get it out, go get a new one, and put it back in. turns out the wiring for the sensor on the back of the DS distro block was smashed, so i hard wired it back in and the engine runs a lottttt smoother. Not entirely sure if it's that, or the fact i also removed my snorkel. i like how the truck sounds a LOT better now. i'm startin to really like this ranger thing steadily lessening my favoring for S-series vehicles :x
__________________
bonestock 89 ranger xlt 2.3l 5spd 2wd. Ridin high (stock), handles like crap, slower than hell, and i love it.

Last edited by blackdout89range; 07-23-2010 at 01:51 PM. Reason: sensor wasnt smashed, wiring was. herppp
Reply With Quote
Reply

Tags
motor, mount, shyte

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken 60/40 armrest? My solution... wvcat Project Logs 3 11-14-2011 04:11 PM
Broken Speedometer in a '93 fishy6301 Interior Tech 11 08-18-2010 11:30 PM
Broken Bolt 99F250Smitty Exhaust and Mufflers 7 07-24-2010 04:17 AM
broken grundle General Ford Ranger Discussion 16 02-17-2010 01:46 AM
Broken wheel stud brannonmetal Drivetrain Tech 1 11-25-2009 08:25 PM