Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-13-2020, 04:12 AM
SHIFTYBUSINESS SHIFTYBUSINESS is offline
Learning to use the forums
 
Join Date: Jun 2013
Posts: 10
Default Starting problem 2.3l

Hey Guys,

My 2002 Ranger is doing something strange. I went to start it and everything was completely dead like the battery was all the way gone. I went back the next day with my charger and when I got in the dome light was on so I put the key and it started up no problem. I drove it around the block with no issue. When I got back I turned it off and went to restart it and it was dead again no dash lights nothing like the battery was disconnected. Also there is the electrical chattering coming from behind the center console dash area close to the floor.

Thanks
Karl
__________________
2002 2.3l 2WD
Reply With Quote
  #2  
Old 01-13-2020, 09:04 AM
barneycat11 barneycat11 is offline
2006 FX4
 
Join Date: Nov 2014
Posts: 363
Default Re: Starting problem 2.3l

I would start by cleaning the battery cables and checking the ground cable for a solid ground.
__________________
barneycat11 2006 FX4
Reply With Quote
  #3  
Old 01-13-2020, 09:59 AM
SHIFTYBUSINESS SHIFTYBUSINESS is offline
Learning to use the forums
 
Join Date: Jun 2013
Posts: 10
Default Re: Starting problem 2.3l

Quote:
Originally Posted by barneycat11 View Post
I would start by cleaning the battery cables and checking the ground cable for a solid ground.
I know the cables are clean because the battery is 3 weeks old but not sure about the ground to the chassis. I will check it after work.
__________________
2002 2.3l 2WD
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem The Grizz 3.0 Vulcan Tech 19 03-03-2014 03:43 PM
Starting problem GREEPER552 3.0 Vulcan Tech 16 01-04-2013 06:50 PM
4.0 starting problem LaBrier 4.0 SOHC / 4.0 OHV Tech 5 03-17-2012 08:32 PM
Rough starting problem as well as high/low idle problem Ins4nity 4-Cylinder Tech 7 02-16-2011 06:10 AM
Starting problem rocky2004 4-Cylinder Tech 1 05-26-2010 12:27 PM