Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-09-2017, 03:25 PM
P_S_F P_S_F is offline
Learning to use the forums
 
Join Date: Sep 2017
Posts: 2
Default Rough Idle, P0171, Tried Everything

2.3L 4-Cyl tried everything.
Started it up a couple weeks ago. Slight pop, smoked a tad, and then was fine. Since that time it has run really rough and Check Engine Light came on. P0171, (Lean) and pending P0113, (Intake air temp sensor circuit high).
So, to remedy, I have:
- Cleaned MAF,
- Replaced PCV,
- Pressure tested/inspected PCV Valve hose that goes up back to intake manifold. Held pressure.
- Tried the brake clean technique for leaks, made it backfire a tad
- Cleaned IAC
Goes 75-80 no problem, never stalled - yet.
I am at a loss.
First post on the forum. However, deeply indebted as this forum has helped in so many other issues.
Thanks for any insight....
__________________
2001 Ranger 2.3L 4-cyl. 5-speed Manual, RWD.

Last edited by P_S_F; 09-09-2017 at 03:29 PM. Reason: add more detail
Reply With Quote
  #2  
Old 09-10-2017, 11:07 AM
tomw0 tomw0 is offline
Ford Ranger Driver
 
Join Date: Aug 2015
Posts: 752
Default Re: Rough Idle, P0171, Tried Everything

"Lean" can be lean from lack of fuel or excess O2, or can be lean interpreted by O2 in the exhaust because of misfire. Misfire leaves the O2:fuel mix intact, so there are O2's floating by the sensor.
A 'pop' can lead to hoses popping off their 'spot' or splitting, thus leaking extra air into the engine that is not measured by the MAF, if you have a MAF. Extra air can cause misfire.
I'd check the vacuum in the intake with the engine running at idle, and also take a look at all vacuum hoses, and even the EGR diaphragm if you have one.
The Lima first had a 'backfire' valve on the PCV line that was spring loaded, and could/would pop out of place on occasion. That made the idle terrible. Once figured out, I knew what was wrong when it happened. I don't think they use that any more.
I'd suggest checking for leaks. If the temp sensor is cooked, they don't cost a lot to replace. It should be screwed into the intake manifold, and easily accessible.
tom
Reply With Quote
  #3  
Old 09-10-2017, 01:56 PM
P_S_F P_S_F is offline
Learning to use the forums
 
Join Date: Sep 2017
Posts: 2
Default Re: Rough Idle, P0171, Tried Everything

Thanks Tom, Appreciate the input. Will check and follow up...
__________________
2001 Ranger 2.3L 4-cyl. 5-speed Manual, RWD.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 Ranger 4.0 OHV P0171-P0174 Rough Idle Houstonlh 4.0 SOHC / 4.0 OHV Tech 4 12-05-2015 03:58 PM
Bad TPS? Idle air control valve? Rough idle and hard time starting Sheribd 3.0 Vulcan Tech 4 09-26-2014 07:35 AM
p0171 slight miss at idle alot worse at 45 mph cpyron13 3.0 Vulcan Tech 10 08-18-2011 02:17 PM
2003 3.0 Ranger - rough low idle (400 rpm), bogs at 2500K, rough shift, NOW FINE Chargerondavins 3.0 Vulcan Tech 1 03-26-2011 04:54 PM