Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-16-2017, 01:26 PM
mrwoodchuck mrwoodchuck is offline
Learning to use the forums
 
Join Date: Sep 2012
Posts: 7
Default Turn signals not working on 1997 ranger...Fixed

I had no turn signals on my 1997 ranger this morning. I read all the post of others. Hate wiring problems. My flashers all worked, no bad bulbs. Replaced the fuse with new. Didn't help. I cleaned around the flasher push butt on steering housing with swabs and blew out around it with air. Pushed flasher button about a dozen times. Turned on turn signals. All now work. Maybe dust,dirt or something crawled in there. Don't know, but all are working well now. Thanks to all that posted before, would have done a lot of work otherwise.
__________________
mrwoodchuck
las vegas, nv

1997 ranger XLT (factory) A/C (no power drs/win) CD (added) 2,3LTR standard trans
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Right turn signals not working ReferJohn Electrical Tech 2 01-22-2014 07:44 PM
4 ways not working but turn signals do? Martinjmpr Electrical Tech 0 01-13-2014 03:02 PM
2003 ranger brake lights and turn signals stop working ehtaylor Electrical Tech 6 05-16-2013 01:12 PM
Turn signals and hazards not working. Please help! Atcroft37 Electrical Tech 4 02-09-2013 06:17 PM
Turn signals not working Poody86 Electrical Tech 8 10-08-2009 08:52 PM