Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 08-13-2017, 05:57 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: 07 2.3L Cranks but no start

Quote:
Originally Posted by Hal_396 View Post
Well messed around with it today. Tried to start and of course it wouldn't. By passed the inertial switch, no start. Pulled the fuel pump relay out again and switched it with the A/c clutch relay and presto, it started. Swapped the relays back and it still started .

I'll check the relay base later but I'm sure it OK.

The wiring diagram doesn't show a driver module. But it is controlled by the PCM. It's an intermittent problem so I'm afraid to take it anywhere until I find a hard fix.

It never has quit while I was driving it. Only when I try and start it after shutting it off. I will try a different key next time it buggers up. It has the chipped anti theft key so maybe the key has gone bad.

I'm trying everything before I change the PCM.
Next time it does not start, test the fuel pressure (gauge is $20) and check for spark

If you put the key in the ignition and the theft light blinks rapidly something is wrong?

Keep checking for codes? Try and catch a pending code?

Clean MAF. Disconnect MAF, does it run better?

Look around the PCM/firewall, is it leaking? Corrosion? If there's no signs of corrosion I doubt it's the PCM, they don't fail often.

The PCV valves are a common fail on these.

Sent from my SM-J320V using Tapatalk

Edit: bad ignition switches can cause a # of odd issues.
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).

Last edited by modelageek; 08-13-2017 at 06:04 AM.
Reply With Quote
  #17  
Old 08-13-2017, 12:16 PM
Hal_396 Hal_396 is offline
Learning to use the forums
 
Join Date: Jul 2017
Posts: 9
Default Re: 07 2.3L Cranks but no start

Quote:
Originally Posted by tomw0 View Post
When you turn the key to ON, does the fuel pump run for a second or two, or does it run and run and run for a longer period of time?
If the pump runs longer than a few seconds, wait until it stops before trying to start the engine. If that works, consistently, check the ECM for dying/dead capacitors, or corroded capacitor lead wires, and repair as noted. That was a failure in the EEC-IV computers due to age and corrosion. Electrolytic capacitors have a 'goo' inside that can dry out over time, and make them non-capacitors, the effects are unreliable.
tom
The fuel pump runs for a second when it will start. When it doesn't start, the fuel pump doesn't run. I'll check PCM in the next few days.

----------

Quote:
Originally Posted by modelageek View Post
Next time it does not start, test the fuel pressure (gauge is $20) and check for spark

If you put the key in the ignition and the theft light blinks rapidly something is wrong?

Keep checking for codes? Try and catch a pending code?

Clean MAF. Disconnect MAF, does it run better?

Look around the PCM/firewall, is it leaking? Corrosion? If there's no signs of corrosion I doubt it's the PCM, they don't fail often.

The PCV valves are a common fail on these.

Sent from my SM-J320V using Tapatalk

Edit: bad ignition switches can cause a # of odd issues.
No fuel pressure at all when in no start condition.
When it starts in runs just fine. So MAF and PCV are more than likely OK.

Checking PCM for anything peculiar in the next day or so. I agree with your comments on the reliability of the PCM's.
Reply With Quote
  #18  
Old 08-14-2017, 05:28 AM
tomw0 tomw0 is offline
Ford Ranger Driver
 
Join Date: Aug 2015
Posts: 738
Default Re: 07 2.3L Cranks but no start

QUOTE:"The fuel pump runs for a second when it will start. When it doesn't start, the fuel pump doesn't run. I'll check PCM in the next few days."

If the fuel pump doesn't run, that's the area to look at. The relay is apparently grounded(enabled) in the 'resting' state of the ECM. The ECM gets power from its relay, wakes up, and removes the ground from the pump relay after about 1 second. If the ECM doesn't wake up, the pump would run continuously.
If the pump doesn't run, check the 'ground' side of the relay socket. One side of the relay control winding will have 12V with the key ON, the other ground, which would enable the coil, and close the relay to send power from the always hot 12v power side of the relay to the pump load side of the relay.
If the relay does not have 12v switched by the key, or doesn't have the 12v always on, check the wire and ignition switch, and for the second, check the power distribution box where the feed comes in for the relay.
tom
Reply With Quote
  #19  
Old 08-14-2017, 03:49 PM
Hal_396 Hal_396 is offline
Learning to use the forums
 
Join Date: Jul 2017
Posts: 9
Default Re: 07 2.3L Cranks but no start

Quote:
Originally Posted by tomw0 View Post
QUOTE:"The fuel pump runs for a second when it will start. When it doesn't start, the fuel pump doesn't run. I'll check PCM in the next few days."

If the fuel pump doesn't run, that's the area to look at. The relay is apparently grounded(enabled) in the 'resting' state of the ECM. The ECM gets power from its relay, wakes up, and removes the ground from the pump relay after about 1 second. If the ECM doesn't wake up, the pump would run continuously.
If the pump doesn't run, check the 'ground' side of the relay socket. One side of the relay control winding will have 12V with the key ON, the other ground, which would enable the coil, and close the relay to send power from the always hot 12v power side of the relay to the pump load side of the relay.
If the relay does not have 12v switched by the key, or doesn't have the 12v always on, check the wire and ignition switch, and for the second, check the power distribution box where the feed comes in for the relay.
tom
Good idea Tom. I've checked the 12V hot side of the relay but not the keyed 12V side, (or grounds). Are the ignition switches prone to fail on Rangers?

It's been working good now for about 20 cycles. I'm still not confident enough to drive it anywhere. I'll keep you guys informed if it fails again or not. Last time it took 3 weeks between episodes.
Reply With Quote
  #20  
Old 09-06-2017, 05:24 PM
Hal_396 Hal_396 is offline
Learning to use the forums
 
Join Date: Jul 2017
Posts: 9
Default Re: 07 2.3L Cranks but no start

Well its been 4 weeks of making short trips close to home and all is well. I have since found a mobile computer service tech that will come out to the house and check the PCM for me if it ever acts up again. Also, if I need to purchase a new PCM, he could program it along with the keys so I can skip the dealer prices.

Keeping the tow trucks phone number close to hand.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ranger Cranks and cranks but wont start!! Jsmitty92 General Tech 4 06-05-2014 06:40 PM
Cranks but won't start BigWill30_06 General Tech 1 02-06-2014 02:17 AM
Cranks but won't start airborne1228 3.0 Vulcan Tech 22 07-16-2013 07:56 AM
Cranks but does not start (sometimes) lewisr 4-Cylinder Tech 4 10-16-2011 12:28 PM
Cranks... But Won't Start RangerFixer 4-Cylinder Tech 23 09-28-2011 01:48 AM