Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 06-24-2010, 07:23 PM
SVT Willis SVT Willis is offline
Liking the Ford Ranger Forum
Join Date: Jan 2010
Posts: 16
Default Truck fixed, want to share problems with you guys.

so i made a thread a couple months ago about my 1987 ranger jerking and 'shutting down' while driving. she would suddenly get no power when driving, slow down and pressing the gas pedal would do nothing. i thought it was the clutch not engaging, since it would suddenly randomly chug, but it had nothing to do with it. I changed the cap/rotor/wires/plugs/and coil, but nothing. i was tired of spending money just guessing, so i went to my mechanic for an $85 diagnostic.

i had these symtoms after i powerwashed the engine.....(i know, why powerwash a worktrucks brother gave me shh for that) so, the problem was the TPS(Throttle position sensor) and ICM (ignition control module, ignition module) were wet still, why after 3 weeks it was still wet, i dont know but they were. my mechanic dried them out and it ran perfect, just got her back today. if it happens again, he recommended changing them both out along with a brand new distributor.

Just a tip, do not powerwash the engine bay. not really worth it if ya dont care what the outside looks like. just glad i found it out.

hopes this helps some of ya.
Reply With Quote
Old 06-24-2010, 07:33 PM
mazdab2300 mazdab2300 is offline
Totally bummed
Join Date: Jun 2010
Posts: 1,106
Thumbs down Re: Truck fixed, want to share problems with you guys.

my truck had the same type of problems but mine ended up being the MAF( mass air flow) censor i took it off to install a cold air intake and just plugged it in and set it by where the air comes in. i dont know why but i left for school and started going put it to the floor and it just stoped basicaly still running but my foot was to the floor and it was just idaling still in 2nd gear. i had to push the clutch in and disengage it again to get it to go then after school when i was at home i unplugged it to set it to the side to look for what was wrong couldnt find anything so i drove it again and it stoped i dont know why either
94 Mazda B2300
jvc head unit scosh hds and xplod speakers also have 2 12 inch subs in the back.
american racing directionals on 30/9.5/15s

Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
hey guys i wanna see a bad truck AngerRanger Vehicle Snapshots 104 06-01-2010 10:47 PM
NSFW: Figured id share sum of my stuff with u guys! kenny216 Photography 42 05-16-2010 11:52 PM
Had to take a pic of this and share! 05RangerEdge Vehicle Snapshots 10 04-26-2010 09:19 AM
what do you guys think of truck boxes? mr.ranger General Ford Ranger Discussion 27 08-08-2009 10:38 AM