Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-19-2010, 09:05 PM
pony50mustang pony50mustang is offline
Learning to use the forums
 
Join Date: Jun 2010
Posts: 1
Default runs like chit

i have a 99 2.5 liter that i have been working on for 3 days now and its wearing my mechanic skills out i did automotive work for 12years and i have never had a truck or car give me this much trouble if anyone has any ideas on what i need to check let me know it would greatly be appreciated i have installed a new timing belt,plugs and wires on this truckand it still runs like chit the timing is dead on i used original iridion plugs or what ever the dam things are called i just know they cost a pretty penny plug wires are good and plugs are to ive double checked them it starts and idles fine but as soon as you give it alittle gas it sounds like its running on two cylinders ive the checked the mass air flow sensor for voltage in and voltage out its good i even swapped with one used for testing when was mechanicing no change in idle still runs rough ive checked all the vac lines nothing is broke or cracked dpfe sensor is working properly,tps is good and iac is good. i can shut the truck off and start it up again and it idles fine but as soon as you give it alittle gas it starts popping back through the intake and running rough again and it loses #3 injector pulse after giving it a little gas do these trucks have problems with pcms going bad or have they had any problems with pcms i have checked recall list and tsbs but no mentions of problems like this that i can find.if anyone has any ideas let me know


thank you
cody
Reply With Quote
  #2  
Old 06-19-2010, 09:34 PM
sgtsandman sgtsandman is offline
Tank Diver
 
Join Date: Mar 2010
Posts: 3,078
Default Re: runs like chit

Try a couple of cheap fixes first. Clean the MAP with MAP sensor cleaner, the IAC with carb/throttle body cleaner and run a tank or two of fuel system cleaner to clean the injectors. For the last part, I like Chevron Techron, Advance runs a BOGO on them from time to time.
__________________
Sgtsandman's Work in Progress
2011 Ranger XLT, 4X4, 4 door Super Cab. 4.0L, 5 Speed M50D-R1HD, 3.73:1, 8.8" open differential, Jason Pace cap
1999 Honda CR-V EX, RT4WD, 2.0L, 5 Speed MT, 4.56:1, open differential
Reply With Quote
  #3  
Old 06-19-2010, 09:39 PM
Vrod21 Vrod21 is offline
Ford Tough
 
Join Date: Dec 2009
Posts: 325
Default Re: runs like chit

Coil pack
__________________
(SOLD) 2003 Ranger 4.0L V6 FX4
2001 F150 Supercrew Triton V8 (DD)
2008 Fusion 3.0L SEL V6 (my baby)
1992 Taurus SHO MTX (my toy-almost Supercharged)
2004 Nissan Murano SL AWD (Wife's car)
Reply With Quote
  #4  
Old 06-19-2010, 09:40 PM
Radarmy088 Radarmy088 is offline
Ford Ranger Owner
 
Join Date: Jun 2010
Posts: 69
Default Re: runs like chit

if it pops through the intake then its igniting the fuel when the intake valve is still open. the timing could be off. if its a distibutorless ignition system there can be a glitch in the pcm. grab a scanner with an o scope and check the crank and cam spikes to see if they line up.
i did a honda that had the same syptoms and the distributor was bad but if it doesnt have one then its controlled by the pcm.
__________________
08 Chevy Colorado 3.7L
too many mods
Reply With Quote
  #5  
Old 06-20-2010, 07:58 AM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: runs like chit

Quote:
Originally Posted by Radarmy088 View Post
if it pops through the intake then its igniting the fuel when the intake valve is still open. the timing could be off.
Add camshaft and crankshaft position sensor to the list of things to check.

I wonder if the plug wires got mixed up and when you installed new ones, and you put them back the way they were? Have you double checked the plugs for proper gap?

No recalls or common problems with the PCM that I've heard of.
Despite the fact that you've been all over this engine and it still runs rough, you still have a very specific symptom.

I know you say you've been over vacuum leaks at the hoses, but have you checked over the throttle body and intake manifold?
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3t first track runs mikesturbo94 General Ford Ranger Discussion 3 04-20-2010 11:41 AM
The first Deranged "OH CHIT, I am gonna die" moment. Dalpilot 8-Cylinder Tech 9 04-01-2010 09:01 AM
Runs like new XJ88 3.0 Vulcan Tech 1 02-22-2010 10:11 PM
2.5 runs BAD turbo54 4-Cylinder Tech 2 09-22-2009 03:08 PM
Runs but dies tj88 3.0 Vulcan Tech 2 08-03-2009 06:42 PM