Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-30-2010, 10:54 PM
TrndAssassin TrndAssassin is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 249
Default Truck wouldn't stay running

first off....
2003 2.3l duratec 5 spd, stock, except for aftermarket wheels and tires.
95,000 miles, fresh oil change, almost time for plugs wires, pcv, and o2 at 100,000

So today I came home from running around, shut my truck off, ran inside, grabbed something, went back out , and left in the truck, made it less then a block, and had to stop to help the neighbor get his vehicle running, so I pull up, shut my truck off...find out the neighbor needs a jump.
So at this point I go to start my truck, it starts up jumps to 1500 rpms or so as usual, and then all a sudden the rpms start to fall down to 0 and the truck dies.
I start it again, same thing.
Start it a 3rd time and plant my foot in it, to keep it runnin and I couldn't get the truck to rev over about 4 grand, took my foot out of the truck, and it idled down to 0 and died.

I got out popped the hood, checked my oil, checked the hoses, pulled my coolant cap off and checked that everything seemed normal.

Got back in the truck, started it up, and it ran just fine the rest of the day
No cel, No Codes, No nothing.......
...so..can someone tell me what was going wrong with my truck lol?
Reply With Quote
  #2  
Old 05-31-2010, 04:06 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: Truck wouldn't stay running

Quote:
Originally Posted by TrndAssassin View Post
first off....
2003 2.3l duratec 5 spd, stock, except for aftermarket wheels and tires.
95,000 miles, fresh oil change, almost time for plugs wires, pcv, and o2 at 100,000

So today I came home from running around, shut my truck off, ran inside, grabbed something, went back out , and left in the truck, made it less then a block, and had to stop to help the neighbor get his vehicle running, so I pull up, shut my truck off...find out the neighbor needs a jump.
So at this point I go to start my truck, it starts up jumps to 1500 rpms or so as usual, and then all a sudden the rpms start to fall down to 0 and the truck dies.
I start it again, same thing.
Start it a 3rd time and plant my foot in it, to keep it runnin and I couldn't get the truck to rev over about 4 grand, took my foot out of the truck, and it idled down to 0 and died.

I got out popped the hood, checked my oil, checked the hoses, pulled my coolant cap off and checked that everything seemed normal.

Got back in the truck, started it up, and it ran just fine the rest of the day
No cel, No Codes, No nothing.......
...so..can someone tell me what was going wrong with my truck lol?
have you ever changed the fuel filter
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 05-31-2010, 07:34 AM
TrndAssassin TrndAssassin is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 249
Default Re: Truck wouldn't stay running

Nope, It Crossed my mind though
Reply With Quote
  #4  
Old 05-31-2010, 08:31 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: Truck wouldn't stay running

Change the filter and get back to us. You ptob should do full tuneup
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #5  
Old 05-31-2010, 08:36 AM
Johnbaum13 Johnbaum13 is offline
<-----Buzz Killington
 
Join Date: Jul 2009
Posts: 1,232
Send a message via Yahoo to Johnbaum13
Default Re: Truck wouldn't stay running

Sounds to me how the d-tech acts when the MAF is unplugged. Check your wires.
__________________
I got my Jesus on the dashboard, but the Devil's under my hood!
Reply With Quote
  #6  
Old 05-31-2010, 09:00 AM
TrndAssassin TrndAssassin is offline
Ford Tough
 
Join Date: Feb 2010
Posts: 249
Default Re: Truck wouldn't stay running

Everythings plugged in,....yes Its time for a full tune up, I cant quite do that till I find a job lol!.....when I get a job , imma do plugs wires, pcv, o2 , air filter, clean the maf, clean the iac, and check the tps,replace the fuel filter and go from there, got a interview tuesday...
If I get the job, all of this will be done next weekend, before I start traveling back n forth to the new job
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why wont my 4.0L Ford Ranger stay running when cold? NeonBoy95 Drivetrain Tech 4 08-29-2010 02:47 AM
lets see what truck caps your running this hunting season.. greyghost Vehicle Snapshots 27 10-05-2009 10:16 PM
cranks but wont stay running sscrash 4-Cylinder Tech 8 07-17-2009 10:11 PM
tryin to get truck running 1995psd 2.9 Liter Tech 4 07-12-2009 05:16 PM
wont stay running Lila General Ford Ranger Discussion 4 05-06-2009 04:04 PM