Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-28-2010, 04:25 PM
rbpguru rbpguru is offline
Learning to use the forums
 
Join Date: May 2010
Posts: 2
Default Spark knock/ping???!!!

I've replaced: air filter, thermostat, both O2 sensors, EGR regulator, Coolant Temp Sensor, New Plugs [8], new wires [8]: After driving approx 15-20 minutes, steady acceleration from between 40-50 MPHr - knocking/pinging occurs. Also, when accelerating, the temp gauge needle falls back and then recovers??? Spending lots, gettin' nuthin!!
Have a new fuel filter in hand. What next? HELP! Thanks a bunch.
__________________
1998 2.5L XLT 163K miles
Reply With Quote
  #2  
Old 05-28-2010, 04:52 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Spark knock/ping???!!!

What grade gas have you been using?

Have you tried cleaning the MAF sensor?
__________________
2005 Edge

Reply With Quote
  #3  
Old 05-29-2010, 08:15 AM
rbpguru rbpguru is offline
Learning to use the forums
 
Join Date: May 2010
Posts: 2
Default Re: Spark knock/ping???!!!

Thanks for the quick response. I failed to note that I have run one full tank of fuel, [87 Octane 10% ethanol] with an injector/fuel line cleaner. I have used a CRC Electrical Contact Cleaner spray on the Mass Air Flow sensor. I may have been overly expecting, but it did seem to make a difference, [for the good] temporarily. Will try your recommendation.
Some people from work have also mentioned a potential vacuum leak and that I spray starter fluid around the vacuum lines/connections with the engine running. If a leak is detected, the engine RPM will increase at the leak source.
Thanks again.
__________________
1998 2.5L XLT 163K miles
Reply With Quote
  #4  
Old 05-29-2010, 08:32 AM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Spark knock/ping???!!!

I was gonna suggest checking for vaccum leak if you had tried the others with no results
__________________
2005 Edge

Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
4.0 engine knock thenewguy 4.0 SOHC / 4.0 OHV Tech 3 04-11-2010 09:58 AM
Knock sensor red87xlt 2.9 Liter Tech 0 03-08-2010 07:53 PM
Loud Ping Noise in Front Pass-Side BenGone Suspension Tech 0 01-28-2010 11:31 AM
diagnose spark knock or ping jim22 3.0 Vulcan Tech 4 11-18-2009 04:20 AM
metal ping sound in reverse doomrus26 Drivetrain Tech 0 09-03-2009 01:39 PM