Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-20-2010, 04:59 AM
sports818 sports818 is offline
Like the Forums
 
Join Date: May 2010
Posts: 34
Default Changed Plugs and Wires, now it chugs

So I just replaced my plugs and wires on my 2001, 2.5l. Now when i started it up it turned on fine, but now there is a chugging. Almost like a cylnder isnt firing or something. When driving it sounds rough, then when slowing down to a stop, it almost dies on me.
What do you think it could be?
I did have to remove the throttle body and intake manifold.
__________________
2001 Ranger, 2.5L, 4 cylinder, XLT, 120+ as of August '11
Reply With Quote
  #2  
Old 05-20-2010, 09:40 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: Changed Plugs and Wires, now it chugs

Quote:
Originally Posted by sports818 View Post
So I just replaced my plugs and wires on my 2001, 2.5l. Now when i started it up it turned on fine, but now there is a chugging. Almost like a cylnder isnt firing or something. When driving it sounds rough, then when slowing down to a stop, it almost dies on me.
What do you think it could be?
I did have to remove the throttle body and intake manifold.
get a code reader and check for pending codes(even if the cel is off). What plugs and wires did you use? Did you get them on correctly? ie. the correct wires to the correct cyl. how about all vacuum tubes did you double check those?
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #3  
Old 05-20-2010, 03:42 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Changed Plugs and Wires, now it chugs

I would say vacuum line or crossed the wires
__________________
2005 Edge

Reply With Quote
  #4  
Old 05-21-2010, 08:51 AM
sports818 sports818 is offline
Like the Forums
 
Join Date: May 2010
Posts: 34
Default Re: Changed Plugs and Wires, now it chugs

Well I figured it out. There are about 800 plugs and hoses to hook up when you take the intake off, well i finished up putting it completely together at night and missed one plug. Not sure what that one plug does, but it apparently was the thing that mattered. So I plugged it ion and now it is all good. These 2.5l can be a pain in the ass sometimes.

By the way, I used motocraft plugs, and autolite wires.
__________________
2001 Ranger, 2.5L, 4 cylinder, XLT, 120+ as of August '11
Reply With Quote
  #5  
Old 05-21-2010, 08:57 AM
modelageek modelageek is offline
Ford Ranger Driver
 
Join Date: Jan 2009
Posts: 6,257
Default Re: Changed Plugs and Wires, now it chugs

Great..........and thanks for following up with a conclusion!!........it helps others down the road
__________________
2004 Ext Cab, 4WD, 4.0, Auto, 154k. (4.0 engine is out of a 2009 Ranger w/96k) ( as of 7/1/2017)

2004 Ranger, Ext Cab, 2WD, 3.0, 5 speed , 4WABS, crank windows, no cruise, Edge 116k.(6/5,2014) (SOLD).
1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD).
Reply With Quote
  #6  
Old 05-21-2010, 01:53 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Changed Plugs and Wires, now it chugs

Quote:
Originally Posted by modelageek View Post
Great..........and thanks for following up with a conclusion!!........it helps others down the road
Agree

Glad to see it was something simple.
__________________
2005 Edge

Reply With Quote
  #7  
Old 05-24-2010, 08:58 AM
sports818 sports818 is offline
Like the Forums
 
Join Date: May 2010
Posts: 34
Default Re: Changed Plugs and Wires, now it chugs

Trust me so am I. I t could have been worse considering when replacing the plugs, I broke a spark plug in the head, and had to remove it. But as anyone who drives a 2.5l knows, the plugs are a b#@!$ to get at. Therefore, I had to take the intake manifold off (which never have done before) and the throttle body (never done before) off to get at the plug I broke. But ended up getting the ceramic part out in one piece with out breaking it, and the tip/threads of the plug out with out losing anything in the engine.
Thanks everyone.
__________________
2001 Ranger, 2.5L, 4 cylinder, XLT, 120+ as of August '11
Reply With Quote
Reply

Tags
spark plugs

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The day that changed my life. stephen.g.fiddes General Ford Ranger Discussion 109 02-23-2011 11:32 PM
What happened: Spark plug and wires changed and now engine sounds rough lcb90 4.0 SOHC / 4.0 OHV Tech 7 05-04-2010 06:26 PM
What changed from 01 to 04? Ranger01 Interior Tech 2 03-30-2010 10:05 AM
just changed drive belt RangerLuc General Ford Ranger Discussion 5 12-02-2009 09:26 PM
my 92 ford ranger 4.0l doesn't have spark, I have new coil pack, plugs and wires? Ruben H 4.0 SOHC / 4.0 OHV Tech 2 07-23-2009 12:16 AM